#3753 (ok 3.5.6) localStorage broken in server status monitor

3.5.5
fixed
Interface (555)
5
2013-06-11
2012-12-14
No

To reproduce:

* go to server status monitor
* do something that will save the monitor settings to the localStorage (rearrange charts, add a chart, change chart columns, etc...)
* reload the page
* the server status monitor errors out a "No Data" exception and does not initialise
* delete monitor settings from localStorage
* reload page
* server status monitor works again

This is particularly bad, since we can't expect users to directly manipulate localStorage

Discussion

  • Rouslan Placella

    • priority: 7 --> 1
    • assigned_to: nobody --> roccivic
    • summary: localStorage broken in server status monitor --> (ok 3.5.6) localStorage broken in server status monitor
    • status: open --> open-fixed
     
  • Rouslan Placella

    This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Marc Delisle

    Marc Delisle - 2013-01-28
    • Status: open-fixed --> closed-fixed
    • Priority: 1 --> 5
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks