#3686 Username with more than 16 digits are cut without warning.

3.5.2
fixed
nobody
Usability (35)
5
2013-06-11
2012-09-25
No

phpmyadmin 3.2.2

I entered a random username by copying. It had 20 digits. Then i copied the 30 digits password too. Then the problem started. I couldnt log in. After searching i found that my username isnt like i stored it but instead its cut after the 16th letter. And that happened without warning. So i searched for the error. Its simply not userfriendly. When there is such restriction then there should be a warning.

Thanks!
Sebastian

Discussion

  • Marc Delisle

    Marc Delisle - 2012-10-13
    • status: open --> wont-fix-invalid
     
  • Marc Delisle

    Marc Delisle - 2012-10-13
    • status: wont-fix-invalid --> open
     
  • Marc Delisle

    Marc Delisle - 2012-10-13

    I got your private email. However, trying to reproduce your problem with version 3.5.2.2, when I enter a username in the "Add user" panel, the input field does not accept more than 16 characters.

    Are you really talking about this panel? phpMyAdmin did not know that you pasted there a 20-character value.

     
  • Marc Delisle

    Marc Delisle - 2012-10-13
    • status: open --> pending
     
  • sebastian333

    sebastian333 - 2012-10-13

    So you mean phpmyadmin or html with javascript cant see that i tried to put in more than the 16 chars? Too bad. I didnt think that there could be such restriction because i dont see a reason for this. There are occasionally websites that only allow passwords that are 20 chars long and dont tell you when you use more. Afterwards you cant login. I never understood why they artificially shorten the abilities. So i dont see here.

    But anyway... when it has to be this way and it cant be catched i have to take it as is. I used the 20 chars because i wanted to create a safe username thats hard to bruteforce. I hope no other persons run into this too.

    Thanks for answering!
    Sebastian

     
  • sebastian333

    sebastian333 - 2012-10-13
    • status: pending --> open
     
  • Marc Delisle

    Marc Delisle - 2012-10-14
    • status: open --> closed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed --> fixed