Help save net neutrality! Learn more.
Close

#3667 (ok 3.5.3) Incorrect updating of the list of users

3.5.2
fixed
Privileges (64)
1
2013-06-11
2012-08-20
No

After updating some db-specific privileges for a user, the list of global privileges for this user in the Users overview page is incorrectly showing these db-specific privileges.

Discussion

  • Ann + J.M.

    Ann + J.M. - 2012-08-21

    Would you mind providing steps to reproduce the problem?

     
  • Marc Delisle

    Marc Delisle - 2012-08-21

    1. on main menu click "Users"
    2. click "Edit privileges" for a user
    3. further down in the panel, in the database-specific privileges, ensure that you have added some privileges for a wildcard database (for example, marc\_% )
    4. go back to the "Edit privileges" panel for the same user and in the database-specific privileges, click "Edit privileges" for this database
    5. add or remove some privileges and click on "Go"
    6. the list of privileges in the Users overview has been incorrectly updated

    I cannot reproduce the problem with a database name not having wildcards in it

     
  • Ann + J.M.

    Ann + J.M. - 2012-08-22
    • assigned_to: nobody --> mynetx
    • status: open --> open-accepted
     
  • Ann + J.M.

    Ann + J.M. - 2012-08-22

    This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Ann + J.M.

    Ann + J.M. - 2012-08-22
    • priority: 5 --> 1
    • summary: Incorrect updating of the list of users --> (ok 3.5.3) Incorrect updating of the list of users
    • status: open-accepted --> open-fixed
     
  • Marc Delisle

    Marc Delisle - 2012-10-08
    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed