#3605 Multiple entries when using "insert as new row"

Latest_Git_snapshot
fixed
5
2013-06-11
2012-06-04
adrianbj
No

When running 9d38c34 from master branch I get a "Firefox has detected that the server is redirecting the request for this address in a way that will never complete." error. Re-browsing the table shows that 20+ new rows have been inserted - all identical to the one I was trying to insert, save the primary key.

Discussion

  • Marc Delisle

    Marc Delisle - 2012-06-05

    Cannot reproduce; please give a step-by-step scenario, including the structure of your table.

     
  • Marc Delisle

    Marc Delisle - 2012-06-05
    • status: open --> pending
     
  • adrianbj

    adrianbj - 2012-06-05
    • status: pending --> open
     
  • adrianbj

    adrianbj - 2012-06-05

    OK, Here is a test table structure that shows the problem. Then simply browse the table, click the edit button beside the one row, choose 'insert as new row' and you should see the problem. Reproducible on other browsers too. Let me know if I can provide any further info.

    -- phpMyAdmin SQL Dump
    -- version 4.0.0-dev
    -- http://www.phpmyadmin.net
    --
    -- Host: localhost
    -- Generation Time: Jun 05, 2012 at 11:20 AM
    -- Server version: 5.1.61-0+squeeze1
    -- PHP Version: 5.3.13

    SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO";
    SET time_zone = "+00:00";

    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
    /*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
    /*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
    /*!40101 SET NAMES utf8 */;

    --
    -- Database: `main`
    --

    -- --------------------------------------------------------

    --
    -- Table structure for table `test`
    --

    CREATE TABLE IF NOT EXISTS `test` (
    `id` int(11) NOT NULL AUTO_INCREMENT,
    `content` text COLLATE utf8_unicode_ci NOT NULL,
    PRIMARY KEY (`id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci AUTO_INCREMENT=2 ;

    --
    -- Dumping data for table `test`
    --

    INSERT INTO `test` (`id`, `content`) VALUES
    (1, 'test');

    /*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
    /*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
    /*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;

     
  • Marc Delisle

    Marc Delisle - 2012-06-06
    • assigned_to: nobody --> lem9
     
  • Marc Delisle

    Marc Delisle - 2012-06-06

    Bug introduced with commit 98cbdfc2b348f21955e9c34bb9f4de2270545631, I'll notify the author of this commit.

     
  • Thilina Abeyrathna

    Hi adrianbj,
    Can you give more info about the bug.

     
  • adrianbj

    adrianbj - 2012-06-13
    • status: open --> closed-fixed
     
  • adrianbj

    adrianbj - 2012-06-13

    Just tested with latest master and it seems to be working fine now - tested my local install and the demo master, so I think this can be closed now.

     
  • Thilina Abeyrathna

    Ok adrianbj, Thanks.

     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks