#3600 Advisor not working on FreeBSD

3.5.1
duplicate
nobody
5
2013-06-11
2012-05-25
Anonymous
No

Fatal error</b>: Call to a member function memory() on a non-object in /var/www/html/phpMyAdmin-3.5.1-all-languages/libraries/Advisor.class.php</b> on line 37.

$Sysinfo is generating an empty array since it's not in the $supported array in sysinfo.lib.php. Since the PHP error isnt exactly valid json it will keep showing the loading icon instead of some kind of error that it's an unsupported os.

PHP version: 5.3.13
Mysql: 5.5.20
PHPMyAdmin: 3.5.1
OS: FreeBSD 9.0 x64

Discussion

  • Michal Čihař

    Michal Čihař - 2012-05-30

    This is caused by missing BSD support in sysinfo class.

     
  • Madhura Jayaratne

    • status: open --> closed-duplicate
     
  • Madhura Jayaratne

    Duplicate of #3562472

     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-duplicate --> duplicate