#3570 Search in table with brackets

3.5.0
out-of-date
AJAX (99)
5
2013-06-11
2012-04-18
Anonymous
No

Situation: a table called "[users]" (yes, with brackets in its name), containing a column "username".
Reproduce the problem: fill the table with some data, then try to search for a username using the search function.
Result: extra instance of the menu bar is displayed, no search results shown even if there are matches in the database

Discussion

  • Rouslan Placella

    I can't reproduce this. Can you reproduce this issue on our demo server?

    http://demo.phpmyadmin.net/

     
  • Rouslan Placella

    • status: open --> pending
     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-05-04
    • status: pending --> open
     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-05-04

    A database called "criminal" has been created on your demo server. It contains a table "[users]" with two rows.
    Open the "[users]" table, click "Search" at the top and enter "maildeamon" in the input field for "login". Hit enter or click "Go", the search frame will be shown twice and the result won't ever be shown at all.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-05-24

    Since the database seems to have been deleted, I have created a new one called bug_3519157. An export is attached to this ticket as well so you can recreate it if needed.

    To reproduce: select the [users] table and click "search" at the top. Enter "johndoe" in the login field and hit enter.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-05-24

    Export of table

     
  • maildeamon

    maildeamon - 2012-07-28

    stil isn,t fixed!!!
    when is there a update ?
    everything always worked fine until last update.
    it realy screwed up the database!

     
  • Madhura Jayaratne

    Can you attach a screenshot of the page you get when you perform the search?

     
  • Madhura Jayaratne

    • status: open --> pending
     
  • Madhura Jayaratne

    Do you have Suhosin(http://www.hardened-php.net/suhosin) on your server?

     
  • Madhura Jayaratne

    I can reproduce this bug on the demo server using the sql export attached to the ticket.
    But this does not seem to be related to brackets in the table name (Same table renamed to `users` also produces the bug), rather to the number of columns in the table.
    What the value of the PHP configuration max_input_vars?
    Can you tell me whether the you can produce the bug with tables having 164 and 165 columns respectively?

     
  • Marc Delisle

    Marc Delisle - 2013-01-18
    • status: pending --> open
     
  • Madhura Jayaratne

    • status: open --> pending
     
  • Madhura Jayaratne

    Cannot reproduce anymore

     
  • Madhura Jayaratne

    • status: pending --> closed-out-of-date
    • assigned_to: Madhura Jayaratne
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-out-of-date --> out-of-date
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks