#3530 Incorrect UPDATE command when columns have comments

3.5.0
works-for-me
nobody
5
2013-06-11
2012-03-13
Ryan O'Hara
No

When inline-editing a column in a row that has a column comment, the comment is included in the UPDATE query and breaks it, forcing a manual edit. For example, a "username" field with a comment of "The user's username" will result in a query similar to the following:

UPDATE somedb.users SET `name
The user's username` = 'Changed' WHERE users.id = 1

Discussion

  • Marc Delisle

    Marc Delisle - 2012-03-13
    • status: open --> pending
     
  • Marc Delisle

    Marc Delisle - 2012-03-13

    Cannot reproduce with a column containing a comment "The user's username".
    Tested with phpMyAdmin 3.5.0-rc1
    PHP 5.3.10
    MySQL 5.6.4-m7
    mysqli and mysqlnd
    Firefox 10.0.2.

    Please attach the export of your table's structure.

     
  • Marc Delisle

    Marc Delisle - 2013-01-18
    • status: pending --> closed-works-for-me
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-works-for-me --> works-for-me
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks