#3524 (ok 4.0) Wrong checkbox behaviour and query creating

3.5.5
fixed
Interface (555)
1
2013-06-11
2012-02-29
dirigeant
No

I have a simple mysql table. It contains two column and doesn't contain any unique column (id, number etc.) If there are two or more lines which contain same value, i can do any operation for all of them.

You can reproduce error with this table schema and data and with these steps:

CREATE TABLE `history` (
`ip` varchar(255) NOT NULL,
`url` text NOT NULL
) ENGINE=MyISAM DEFAULT CHARSET=utf8

INSERT INTO `history` VALUES ('','http://www.someurl.org/'),('','http://www.someurl.org/');

- Open browse page for table,
- Click checkbox of firstline,
- Click checkhox of secondline (First error: when you check second line it doesn't work properly at first click.)
- Click again checkbox of secondline. Both of checboxes should be selected now.
- Click "delete selecteds" (Second error: it deletes only one of them.)

Discussion

  • Atul Pratap Singh

    The problem is with changing/deleting multiple identical row entries. I have submitted a patch solving the issue (https://sourceforge.net/tracker/?func=detail&aid=3500882&group_id=23067&atid=377410).
    Though I wasn't able to reproduce the mentioned "First error" in latest branch master.

     
  • Marc Delisle

    Marc Delisle - 2012-04-22

    This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Marc Delisle

    Marc Delisle - 2012-04-22
    • priority: 5 --> 1
    • assigned_to: nobody --> lem9
    • summary: Wrong checkbox behaviour and query creating --> (ok 4.0) Wrong checkbox behaviour and query creating
    • status: open --> open-fixed
     
  • Marc Delisle

    Marc Delisle - 2013-01-22
    • milestone: 3.3.10 --> 3.5.5
     
  • Marc Delisle

    Marc Delisle - 2013-05-03
    • Status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks