#3492 (ok 3.4.10) license issue with tcpdf

3.4.7
fixed
PDF (31)
1
2013-06-11
2011-12-16
No

please also review: https://bugzilla.novell.com/show_bug.cgi?id=736698

phpMyAdmin 3.4.7.1 (and presumably many earlier versions as well) contains
tcpdf. This package claims to be LGPL-3.0+ licensed but contains the following
clause:

Additionally,
YOU CAN'T REMOVE ANY TCPDF COPYRIGHT NOTICE OR LINK FROM THE
GENERATED PDF DOCUMENTS.

As the LGPL-3.0+ incorporates by reference the GPL-3.0+, sections 7 and 10 of
the GPL-3.0+ are relevant:

All other non-permissive additional terms are considered "further
restrictions" within the meaning of section 10. If the Program as you
received it, or any part of it, contains a notice stating that it is
governed by this License along with a term that is a further
restriction, you may remove that term. If a license document contains
a further restriction but permits relicensing or conveying under this
License, you may add to a covered work material governed by the terms
of that license document, provided that the further restriction does
not survive such relicensing or conveying.

Accordingly, it may be possible to point out to tcpdf upstream that the
additional term that they apply may be viewed as a 'non-permissive restriction'
and that you wish to exercise your rights under the GPL-3.0+ to remove that
term from downstream distributions.

If upstream are unwilling to engage in meaningful discussion or take the view
that the additional restriction is per se not part of the license because it is
above the license and not incorporated into it, tcpdf should be dropped.

Discussion

  • Marc Delisle

    Marc Delisle - 2011-12-16

    Jim,
    with my usual Novell login, I get "You are not authorized to access bug #736698."

     
  • Christian Wittmer

    tell me your novell login and I'll add you to the CC list of bnc#736698
    This should give you enough rights then.
    If this won't work I'll keep you updated here.

    P.S.: my initial post here is a copy of bnc#736698

     
  • Michal Čihař

    Michal Čihař - 2011-12-16

    For my bugzilla access it would be mcihar@suse.com.

    Anyway I don't see how it would be problem for phpMyAdmin. According to section 7 we should be allowed to drop this clausule. I think you should rather discuss this with TCPDF.

     
  • Marc Delisle

    Marc Delisle - 2011-12-16

    I have contacted Nicola Asuni about this.

    Michal, I agree that we drop this clausule in our trees, for the final 3.4.9 release.

     
  • Nicola Asuni

    Nicola Asuni - 2011-12-16

    The additional terms on TCPDF are not "non-permissive" but just clearly enforce what is already covered by the license itself. Indeed, removing or changing copyright notices from a GNU-LGPL software is still prohibited, even without the additional term. In any case the copyright notice included by default in TCPDF are hidden, so I do not understand where the problem is or how can this interfere with phpMyAdmin.
    In any case the original license terms must be keep intact.

     
  • Michal Čihař

    Michal Čihař - 2011-12-20

    @nicolaasuni: There is good reasoning why additional terms are not good is described at https://lists.fedoraproject.org/pipermail/legal/2011-June/001656.html (though this is not about TCPDF, the Producer Line Restriction quite matches issue we face here). Redhat lawyer there writes (among other things) that the section 7 would give them permission to remove this part from license, though this is not way they want to go and keeping this restriction makes the license incompatible with Fedora legal policies.

    Given that both Redhat/Fedora and SUSE see such license additions problematical, we will have to find some solution for phpMyAdmin, either being it removal of such addition from license or stop using TCPDF.

     
  • Nicola Asuni

    Nicola Asuni - 2012-01-28

    On the latest TCPDF version (5.9.145) the license terms were updated to remove additional restrictions to the original GNU-LGPLv3 license. Please also note that on the default TCPDF distribution some third party fonts with different licenses are included. These fonts are not required by TCPDF but have been included as you convenience. The original TTF font files have been renamed for compatibility with TCPDF and compressed using the gzcompress PHP function that uses the ZLIB data format (.z files).
    To get the original distribution archives please check the information on fonts subfolders:
    - DejaVu fonts 2.33 (Bitstream) - Copyright, License and other info: fonts/dejavu-fonts-ttf-2.33
    - GNU FreeFont (GNU-GPLv3) - Copyright, License and other info: fonts/freefont-20100919

     
  • Christian Wittmer

    Marc,
    please tell me your Novell LOGIN, then I can add you to cc-list of bnc#736698.

     
  • Christian Wittmer

    Nicola,
    pls forgt my last comment. :)
    Thanks for info

     
  • Marc Delisle

    Marc Delisle - 2012-01-28

    Nicola: thanks for your cooperation

    Christian: my Novell login is lem9 and I already have access to bnc#736698.

     
  • Madhura Jayaratne

    • assigned_to: nobody --> madhuracj
     
  • Madhura Jayaratne

    Updated to TCPDF version 5.9.145

     
  • Madhura Jayaratne

    • priority: 5 --> 1
    • summary: license issue with tcpdf --> (ok 3.4.10) license issue with tcpdf
    • status: open --> open-fixed
     
  • Madhura Jayaratne

    This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Marc Delisle

    Marc Delisle - 2012-02-14
    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed