#3305 (ok 3.5) Row check boxes missing when row links are disabled

Latest_Git_snapshot
fixed
nobody
Interface (555)
1
2013-06-11
2011-05-16
No

If you disable both "Show table row links on left side" and "Show table row links on right side" in your configuration (see below for exact steps to reproduce), the row checkboxes are no longer visible. "Check all" appears to have no effect as well.

Steps to reproduce:

1. Settings -> Main Frame -> Browse mode
2. Uncheck both "Show table row links on left side" and "Show table row links on right side"
3. Save
4. Browse a table -- you'll notice the checkboxes next to each row are missing as well.

Affects:

* phpMyAdmin 3.4.0 (release)
* phpMyAdmin-master-20110516-022001 (snapshot)

Tested with:
* Chromium 11.0.696.65 (84435) Ubuntu 11.04
* Firefox 4.0.1

Discussion

  • Rouslan Placella

    I'm now quite sure why anyone would want to disable both...

    What kind of makes sense to me now is to just change the two check boxes to a drop down list, like this:
    http://www.placella.com/pma/row_links_config.png
    This way the user can't make the checkboxes disappear in the first place (not through the GUI anyway).

    Thoughts?

     
  • Marc Delisle

    Marc Delisle - 2011-05-18

    @roccivic1, two directives are touched by this, ModifyDeleteAtLeft and ModifyDeleteAtRight. I think it would be tricky to manipulate both with the current logic of user preferences. Also, they could still be set to false directly in config.inc.php.

    So we would need to merge these into just one directive that has three values as you suggest.

     
  • Rouslan Placella

    @lem9: care for patch (target 3.5.0)? Or are we happy with these config options as they are?

     
  • Marc Delisle

    Marc Delisle - 2011-05-18

    @roccivic, yes I would like a patch, especially now that these directives are no longer correctly named. It could become RowActionLinks.

     
  • Kian Mohageri

    Kian Mohageri - 2011-05-18

    @roccivic1, I want to disable the inline buttons because they're unnecessary and make the table a little cluttered. If I'm just browsing data (which most of the time I am), I don't necessarily need to see inline edit buttons for every row.

     
  • Michal Čihař

    Michal Čihař - 2011-06-02
    • priority: 5 --> 1
    • summary: Row check boxes missing when table row links are disabled --> (ok 3.5) Row check boxes missing when row links are disabled
    • status: open --> open-fixed
     
  • Michal Čihař

    Michal Čihař - 2011-06-02

    This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Marc Delisle

    Marc Delisle - 2012-04-07
    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks