#3293 chrome: database change in sidebar doesn't trigger refresh

fixed
None
5
2013-06-11
2011-05-10
flokli
No

When I try to switch the database in the sidebar, all I get is a javascript error:

Uncaught TypeError: Cannot read property 'document' of undefined in common.js:104

on gentoo x86 chromium-12.0.742.21

there is also a javascript error

Cannot read property 'document' of undefined in common.js:268

when I click the "Databases" tab.

(using pmahomme theme which is now default)

Discussion

  • Ata S.

    Ata S. - 2011-06-19

    I totally agree about this bug and it should be fixed. The sidebar doesn't work with the newest pma when changing databases.

     
  • flokli

    flokli - 2011-07-20

    now the error when switching databases is in common.js:32

    still "Uncaught TypeError: Cannot read property 'document' of undefined"

    the same error also occurs on in common.js:352 and common.js:196.

    Any ideas?

     
  • Felix

    Felix - 2011-10-18

    I've experienced the same problem, on my desktop computer using win 7 pro x64, chrome v14 and phpmyadmin version 3.4.3.1 (and 3.4.6) the side bar doesn't refresh and i just see the js error "Uncaught TypeError: Cannot read property 'document' of undefined" on line 2 or 7 or 13.

    The strange thing is, when using my laptop (win 7 ultimate x64, chrome v14) which has a local wamp server on it and php myadmin (3.4.3.2) i have no issues changing the database using the drop down box. I've not tried using 3.4.3.1 or 3.4.6 on my laptop so i can't quite say if i have the same issues as on my desktop, but it would be nice to have this problem fixed.

     
  • flokli

    flokli - 2011-10-18

    Could you try on http://demo.phpmyadmin.net/master/ ?
    This is always the current version from git.

    (user root, no password)

    I now see

    Uncaught TypeError: Cannot read property 'document' of undefined in common.js:1

    chromium-15.0.874.83 on gentoo amd64

     
  • Marc Delisle

    Marc Delisle - 2011-12-29
    • status: open --> pending
     
  • Marc Delisle

    Marc Delisle - 2011-12-29

    I cannot reproduce this problem on Windows Vista with Chrome 16, testing http://demo.phpmyadmin.net/master

     
  • flokli

    flokli - 2011-12-30
    • status: pending --> open
     
  • Marc Delisle

    Marc Delisle - 2012-01-11
    • status: open --> pending
     
  • Marc Delisle

    Marc Delisle - 2012-01-11

    Do you have the same problem with version 3.5.0-alpha1 ?

     
  • Ata S.

    Ata S. - 2012-01-11

    Could reason be the "MeasureIt!" extension if it is installed? Or any other extension? I don't get the problem now.

     
  • flokli

    flokli - 2012-01-11

    You are right, thank you!
    After disabling MeasureIt!, it works!

    Do you have any idea how this extension triggers this problem?

     
  • flokli

    flokli - 2012-01-11
    • status: pending --> open
     
  • flokli

    flokli - 2012-01-11

    There's a comment on the MeasureIt! extension page:

    I noticed on some pages JavaScript was failing, so I checked Chrome Console and I noticed this error:

    "Uncaught TypeError: Cannot call method 'appendChild' of undefined"
    chrome-extension://aonjhmdcgbgikgjapjckfkefpphjpgma/measureIt.js:30

    When MeasureIt extension is disabled - problem goes away.

    The problem is on this line of measureIt.js - "var _body = document.getElementsByTagName('body') [0];". Pages with frames frequently don't have <body> tag, instead <frameset> tag goes right after closing <head> tag.

     
  • Marc Delisle

    Marc Delisle - 2012-01-11
    • assigned_to: nobody --> lem9
    • status: open --> closed
     
  • Marc Delisle

    Marc Delisle - 2012-01-11

    Added this FAQ for 3.5.0-beta1:
    5.19 I get JavaScript errors in my browser.

    Issues have been reported with some combinations of browser extensions. To troubleshoot, disable all extensions then clear your browser cache to see if the problem goes away.

     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks