#3252 "Delimiter" field in query will switch back to default

3.3.9
fixed
nobody
None
5
2013-06-11
2011-03-27
Pekka
No

When entering a stored procedure in the "Run SQL query" textarea, you will want to remove the "delimiter" character for the procedure to parse properly. (See screenshot). Even if you remove it, the default delimiter character will snap back into place after you submit the query. This is unexpected and counter-intuitive.

Steps to reproduce:
1. Go to "SQL" tab
2. Empty the "delimiter" field
3. Enter an invalid query and submit it
4. After submission, an error message will appear and the delimiter will be back to ";".

Expected behaviour:
The delimiter should remain empty.

Discussion

  • Pekka

    Pekka - 2011-03-27
     
  • Pekka

    Pekka - 2011-03-27

    Ahh, I understand what the "Delimiter" field is supposed to do now - I have little experience with Stored Procedures. This may be intended behaviour.

     
  • Aamir Khan

    Aamir Khan - 2011-03-28

    This isn't a bug and there is no real time situation in which user will be changing the delimiter specifically

     
  • Marc Delisle

    Marc Delisle - 2011-04-14
    • status: open --> pending
     
  • SourceForge Robot

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending --> closed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed --> fixed