#3250 (ok 3.4.0-rc1) Inline Edit - SQL syntax error #1064

Latest_Git
fixed
AJAX (99)
1
2013-06-11
2011-03-25
No

Inline Edit on a row with a comma-separated value list in a field returns :
'#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '%60alias%60.%60alias%60+%3D+%27cacti-risq%27' at line 1'
With Firefox 3.6.12 and Internet Explorer 8.0.6001.18702
PHPMyAdmin 3.4.0-rc1-dev

Discussion

  • Philippe Gosselin

    Error print screen, table structure print screen

     
  • Philippe Gosselin

    • assigned_to: nobody --> lem9
     
  • Marc Delisle

    Marc Delisle - 2011-03-25

    Thanks for the report, but something is missing.

    When you create a bug report, the top message says "Provide easy steps to reproduce and if possible include your table structure (SHOW CREATE TABLE `tbl_name`); if your problem implies specific data, attach a small export file for sample rows. "

     
  • Marc Delisle

    Marc Delisle - 2011-03-26
    • assigned_to: lem9 --> nobody
     
  • Anonymous - 2011-03-29

    Hi,

    Can u explain what exactly happed. Because , in line editing worked fine for me.

    Regards,

    Gayan

     
  • Philippe Gosselin

    Create table and sample rows. Default options for Export.

     
  • Philippe Gosselin

    Some rows are unaffected. For example, row with alias 'cacti-risq' gets an error when I click 'Inline Edit', alias 'urgence' does too, while alias 'concoursmath' does not.

    I joined some other samples that do not get any error.

     
  • Philippe Gosselin

    I forgot: If I did 'Inline Edit' on an affected rows, then saving it, it no longer got any error afterwards. I will try and test my sample data to make sure it contains what provokes the error.

     
  • Madhura Jayaratne

    • assigned_to: nobody --> madhuracj
     
  • Madhura Jayaratne

    • labels: 438488 --> AJAX
    • milestone: --> Latest_Git
    • priority: 5 --> 1
    • summary: Inline Edit - SQL syntax error #1064 - comma-separated field --> (ok 3.4.0-rc1) Inline Edit - SQL syntax error #1064
    • status: open --> open-fixed
     
  • Madhura Jayaratne

    This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Philippe Gosselin

    For the record, I finally tested my sample data. Glad it was useful.

     
  • Philippe Gosselin

    Indeed, we did try your fix and the bug no longer occurs according to my limited tests. (tested original data, then an import of the sample data).

    Thanks.

     
  • Marc Delisle

    Marc Delisle - 2011-04-16
    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks