#3120 (ok 4.3) events are not exported when using xml

3.3.7
fixed
1
2014-12-05
2010-09-27
No

When exporting as xml, events are not exported.

Discussion

  • Aamir Khan

    Aamir Khan - 2010-11-15

    i would like to debug this.

     
  • Aamir Khan

    Aamir Khan - 2010-11-15

    what are events in database?

     
  • Aamir Khan

    Aamir Khan - 2010-12-07

    I think the bug is solved in 3.4.0 - aplha 2..
    I tried exporting as XML and again importing the events exported and imported successfully.

     
  • Aamir Khan

    Aamir Khan - 2010-12-08

    i think the bug doesn't exist anymore..
    if it does..then let me know..
    else close this bug ticket

     
  • Dieter Adriaenssens

    For some reason, the xml export option was not available when I tried to test. I will check this later.

     
  • Dieter Adriaenssens

    I tested with master (3.4-alpha3) and events are not exported (and later imported) with xml. In my case not even all tables were exported, but I'll look into that later.

    BTW: When importing the xml-file, make sure you change the name of the database in the xml-file, and go to top level when importing. If you import an xml file in a database, then the tables will be imported into the current database, ignoring the database specified in the xml file.

     
  • Aamir Khan

    Aamir Khan - 2010-12-10

    the tables having some values in it and can be browsed are imported back only.....
    if the events table is empty then it will not come back as you import back the contents from exported XML file..

    I think the problem is with XML import...i am looking in this matter

     
  • Aamir Khan

    Aamir Khan - 2010-12-10

    i will also try to have one plugin for XML server exporting...for server_export.php

     
  • Aamir Khan

    Aamir Khan - 2010-12-12

    patch is submitted for xml database exporting of tables

     
  • Dieter Adriaenssens

    bug will be introduced when xml export 'schema structure' option is added
    (when patch #3135414 will be commited to 3.5-dev)

     
  • Dieter Adriaenssens

    • milestone: 1232560 -->
    • priority: 5 --> 3
     
  • Dieter Adriaenssens

    • priority: 3 --> 5
     
  • Madhura Jayaratne

    • assigned_to: Madhura Jayaratne
    • Group: --> 3.3.7
     
  • Madhura Jayaratne

    • summary: events are not exported when using xml --> (ok 4.3) events are not exported when using xml
    • status: open --> resolved
    • Priority: 5 --> 1
     
  • Marc Delisle

    Marc Delisle - 2014-12-05
    • Status: resolved --> fixed