#3072 (ok 3.4) Multiple servers with signon authentication

3.3.5
fixed
1
2013-06-11
2010-08-04
Will Palmer
No

I tried to set up signon-based authentication for phpmyadmin, but when using multiple servers with this set-up, the same username, password, and hostname, is being used for all configured servers. It works fine for a single server, and having one signon-based, one config-based, etc, also works. But for multiple servers where all servers use signon-based authentication, this just isn't working.

Testing by putting a simple die() in the signon script shows that the signon URL isn't actually getting called when switching between configured servers via the dropdown on the main PHPMyAdmin page. Is this a bug, or am I missing something?

Discussion

  • Will Palmer

    Will Palmer - 2010-08-04

    Sorry, forgot to mention, the version I am using does not appear in the drop-down. I am using RELEASE_3_3_5

     
  • Marc Delisle

    Marc Delisle - 2010-08-05
    • assigned_to: nobody --> lem9
     
  • Marc Delisle

    Marc Delisle - 2010-08-05

    Thanks for the report, I'll have to test this scenario.

     
  • Marc Delisle

    Marc Delisle - 2010-10-18
    • assigned_to: lem9 --> nobody
    • milestone: 284141 --> 284140
    • labels: 509109 --> Security / Restrictions
     
  • Marc Delisle

    Marc Delisle - 2010-10-18

    I did not have time to test this. Moved to bugs.

     
  • Marc Delisle

    Marc Delisle - 2010-10-18
    • milestone: 284140 --> 3.3.5
     
  • Michal Čihař

    Michal Čihař - 2011-03-18
    • assigned_to: nobody --> nijel
     
  • Michal Čihař

    Michal Čihař - 2011-03-18

    Indeed, signon was not design with more servers in mind. I guess your configuration has different signon URL for each server, but same session name? This case should be fixable and you can workaround it by using different session name for each url.

     
  • Michal Čihař

    Michal Čihař - 2011-03-18
    • summary: Multiple servers with signon authentication --> (ok 3.4) Multiple servers with signon authentication
    • priority: 5 --> 1
    • status: open --> open-fixed
     
  • Michal Čihař

    Michal Čihař - 2011-03-18

    This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Marc Delisle

    Marc Delisle - 2011-05-11
    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks