#2811 NULL checkbox do not work on foreign key column editation

3.1.0
duplicate
Interface (555)
5
2013-06-11
2008-12-18
No

NULL checkbox do not work on foreign key column editation

when editing a row, the NULL checkbox do not clear the previous value of column. even if the value is deleted from textbox manually, the resulting query is wrong and results in:
"#1452 - Cannot add or update a child row: a foreign key constraint fails ..."

Discussion

  • Marc Delisle

    Marc Delisle - 2008-12-19
    • assigned_to: nobody --> lem9
    • status: open --> pending-duplicate
     
  • Marc Delisle

    Marc Delisle - 2008-12-19

    Looks like a duplicate of bug #1253252.

     
  • Vlasta Neubauer

    Vlasta Neubauer - 2009-01-06

    yes it is. in rev 12170 it is fixed. thanks

     
  • Vlasta Neubauer

    Vlasta Neubauer - 2009-01-06
    • status: pending-duplicate --> closed-duplicate
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-duplicate --> duplicate
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks