#2477 (ok 2.11.3) Renaming a database containing a VIEW

2.10.2
fixed
5
2013-06-11
2007-07-19
No

In 2.10.2, syntax error.
In 2.10.3-rc1, the rename works, the new VIEW points correctly to the new table, but there is an extra DROP TABLE generated for this view. This produces an error and the left panel is not updated correctly.

Discussion

  • MSD Informatique

    Logged In: YES
    user_id=1636250
    Originator: NO

    I experienced the same problem with 2.10.3

    All the tables get copies, but the views are not. It fails with a message saying cannot drop table followed by the name of the view

    Let me know if I can be of any help

     
  • Richie

    Richie - 2007-10-04

    Logged In: YES
    user_id=1905557
    Originator: NO

    Looks like this has been fixed in the SVN trunk.

     
  • Marc Delisle

    Marc Delisle - 2007-12-23
    • assigned_to: nobody --> lem9
    • summary: Renaming a database containing a VIEW --> (ok 2.11.3) Renaming a database containing a VIEW
    • status: open --> closed-fixed
     
  • Marc Delisle

    Marc Delisle - 2007-12-23

    Logged In: YES
    user_id=210714
    Originator: YES

    Yes, cannot reproduce under 2.11.3.

     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed