#2427 (ok 2.11.0-rc2) Error, while updating \"text\" column data

2.10.1
fixed
1
2013-06-11
2007-05-11
No

I updated about 10KB of text in column, named val. Its type is text. Then I received PHP error:

Warning: Invalid argument supplied for foreach() in phpMyAdmin-2.10.1\tbl_replace.php on line 209

Warning: Cannot modify header information - headers already sent by (output started at phpMyAdmin-2.10.1\tbl_replace.php:209) in phpMyAdmin-2.10.1\libraries\ob.lib.php on line 64

Warning: Cannot modify header information - headers already sent by (output started at phpMyAdmin-2.10.1\tbl_replace.php:209) in phpMyAdmin-2.10.1\libraries\header_http.inc.php on line 13

Warning: Cannot modify header information - headers already sent by (output started at phpMyAdmin-2.10.1\tbl_replace.php:209) in phpMyAdmin-2.10.1\libraries\header_http.inc.php on line 14

Warning: Cannot modify header information - headers already sent by (output started at phpMyAdmin-2.10.1\tbl_replace.php:209) in phpMyAdmin-2.10.1\libraries\header_http.inc.php on line 15

Warning: Cannot modify header information - headers already sent by (output started at phpMyAdmin-2.10.1\tbl_replace.php:209) in phpMyAdmin-2.10.1\libraries\header_http.inc.php on line 16

Warning: Cannot modify header information - headers already sent by (output started at phpMyAdmin-2.10.1\tbl_replace.php:209) in phpMyAdmin-2.10.1\libraries\header_http.inc.php on line 19

In the text weren't any special chars. There were only quotes. Thanks for help.

Discussion

  • Marc Delisle

    Marc Delisle - 2007-05-25
    • assigned_to: nobody --> lem9
    • status: open --> pending
     
  • Marc Delisle

    Marc Delisle - 2007-05-25

    Logged In: YES
    user_id=210714
    Originator: NO

    Please attach a small export of your table's structure and data.

    Also, which PHP version and are you running Zend Optimizer?

     
  • SourceForge Robot

    • status: pending --> closed
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • mickesenna

    mickesenna - 2007-07-23

    Logged In: YES
    user_id=1838021
    Originator: NO

    I encountered this exact problem too. I can submit the table if needed.

     
  • mickesenna

    mickesenna - 2007-07-24

    Logged In: YES
    user_id=1838021
    Originator: NO

    Here a small exported portion of the table:
    -- phpMyAdmin SQL Dump
    -- version 2.10.1
    -- http://www.phpmyadmin.net
    --
    -- Host: metso.sigmatic.fi
    -- Generation Time: Jul 01, 2007 at 03:26 PM
    -- Server version: 4.1.15
    -- PHP Version: 4.4.7-0.dotdeb.0

    SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO";

    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
    /*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
    /*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
    /*!40101 SET NAMES utf8 */;

    --
    -- Database: `funkywc_micke`
    --

    -- --------------------------------------------------------

    --
    -- Table structure for table `content`
    --

    DROP TABLE IF EXISTS `content`;
    CREATE TABLE IF NOT EXISTS `content` (
    `nail` int(11) NOT NULL default '0',
    `page` varchar(20) NOT NULL default '',
    `section` varchar(20) NOT NULL default '',
    `fin` text,
    `swe` text,
    `eng` text,
    KEY `nail` (`nail`)
    ) ENGINE=MyISAM DEFAULT CHARSET=latin1;

    --
    -- Dumping data for table `content`
    --

    INSERT INTO `content` (`nail`, `page`, `section`, `fin`, `swe`, `eng`) VALUES
    (0, 'heinlein_index', 'text', NULL, NULL, '<h1>Robert A. Heinlein - The Dean of Science Fiction</h1>\r\n<p>This is NOT a market place. I just happen to like Robert''s writings very very much and want to give some information if\r\nsomebody needs it. All of these books can be found in my bookshelf. Some in swedish, my native language, but mostly in english. So if you want a book from my list, try <a\r\n href="http://www.amazon.co.uk/"><img src="smile-amazon-logo-200x45.gif"\r\n align="top" border="0" width="200" height="45"></a>, or take the\r\nISBN, go down to your local book store and pray it still is on their list.</p>\r\n<p>All the ISBN:s should be correct, but my versions of "Life-Line", "Ordeal in Space" and\r\n"Misfit" came to me without ISBN, but because my software needs the ISBN to let me put the book in my system, I looked up the ISBN:s in an old American book catalog.</p>\r\n<p>Don''t pay too much attention to the year printed because it may either be when the book was printed first time or when my particular copy is printed or copyrighted</p>\r\n<p>I am probably breaking copyright laws making this page, but I hope, with all my heart, for understanding. I am not getting any\r\nprofit from this page. And if somebody still feels hard done by it, please e-mail me and I''ll remove it.</p>\r\n<p>Robert A. Heinlein was born in Butler, Missouri 1907, but lived his\r\nchildhood in Kansas City where he saw the\r\nHalley''s Comet fly through the sky in 1910, a sight that is said\r\nto have made a deep impression on him. He died on the 8th of may\r\n1988 after a brilliant life as a writer of Science Fiction. Below\r\nare most, but not all, of his achievements</p>')

     
  • Marc Delisle

    Marc Delisle - 2007-07-24
    • assigned_to: lem9 --> nobody
    • status: closed --> open
     
  • Marc Delisle

    Marc Delisle - 2007-08-19
    • assigned_to: nobody --> lem9
     
  • Marc Delisle

    Marc Delisle - 2007-08-19

    Logged In: YES
    user_id=210714
    Originator: NO

    Thanks for the sample.
    With PHP 5.2.4RC2: no problem.

    With PHP 4.4.7: bug confirmed with 2.10.3, but fixed in 2.11.0-rc2.

     
  • Marc Delisle

    Marc Delisle - 2007-08-19
    • summary: Error, while updating "text" column data --> (ok 2.11.0-rc2) Error, while updating "text" column data
    • priority: 5 --> 1
    • status: open --> open-fixed
     
  • Marc Delisle

    Marc Delisle - 2007-08-21
    • summary: (ok 2.11.0-rc2) Error, while updating "text" column data --> (ok 2.11.0-rc2) Error, while updating \"text\" column data
    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks