#1928 (in 2.7.1) Call undefined:pma_generate_common_url()

2.7.0-pl1
fixed
1
2015-01-18
2005-12-22
No

I executed a sql-query to check some consistency of my
database:

SELECT events. *
FROM `events` , kalender_structure
WHERE events.Structure_ID = kalender_structure.Structure_ID
AND events.SSID != kalender_structure.kalender_id
ORDER BY `SSID` ASC
LIMIT 0 , 30

I get the following errors with phpMyAdmin 2.7.0-pl1
and
MySQL 4.0.18

When I try to edit a result-record:
Fatal error: Call to undefined function:
pma_generate_common_url() in
/srv/www/htdocs/community.scoutnet.de/public_html_ssl/kalender/phpmyadmin_/libraries/header_meta_style.inc.php
on line 44

When I try to delete one:
Fatal error: Call to undefined function:
pma_dbi_try_query() in
/srv/www/htdocs/community.scoutnet.de/public_html_ssl/kalender/phpmyadmin_/libraries/check_user_privileges.lib.php
on line 16

Thx for your work on phpmyadmin!!!

debug_backtrace() before the error-lines:

Array
(
[0] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/header.inc.php
[line] => 26
[function] => require_once
)

[1] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/tbl_change.php
[line] => 11
[args] => Array
(
[0] =>
/<deleted-for-privacy>/phpmyadmin_/header.inc.php
)

[function] => require_once
)

[2] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/grab_globals.lib.php
[line] => 169
[args] => Array
(
[0] =>
/<deleted-for-privacy>/phpmyadmin_/tbl_change.php
)

[function] => require
)

[3] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/common.lib.php
[line] => 51
[args] => Array
(
[0] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/grab_globals.lib.php
)

[function] => require_once
)

[4] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/tbl_row_action.php
[line] => 4
[args] => Array
(
[0] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/common.lib.php
)

[function] => require_once
)

)

Array
(
[0] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/check_user_privileges.lib.php
[line] => 30
[function] => pma_issuperuser
[args] => Array
(
)

)

[1] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/sql.php
[line] => 10
[args] => Array
(
[0] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/check_user_privileges.lib.php
)

[function] => require_once
)

[2] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/grab_globals.lib.php
[line] => 169
[args] => Array
(
[0] =>
/<deleted-for-privacy>/phpmyadmin_/sql.php
)

[function] => require
)

[3] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/common.lib.php
[line] => 51
[args] => Array
(
[0] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/grab_globals.lib.php
)

[function] => require_once
)

[4] => Array
(
[file] =>
/<deleted-for-privacy>/phpmyadmin_/tbl_row_action.php
[line] => 4
[args] => Array
(
[0] =>
/<deleted-for-privacy>/phpmyadmin_/libraries/common.lib.php
)

[function] => require_once
)

)

Discussion

  • Christopher Vogt

    • summary: Call to undefined function(s): pma_generate_common_url() --> Call undefined:pma_generate_common_url() pma_dbi_try_query()
     
  • Marc Delisle

    Marc Delisle - 2005-12-30
    • assigned_to: nobody --> lem9
     
  • Marc Delisle

    Marc Delisle - 2005-12-30

    Logged In: YES
    user_id=210714

    Could you attach here the export of your 2 tables please?

     
  • debser

    debser - 2006-01-04

    Logged In: YES
    user_id=1418937

    Hello,

    I have the same Problem, trying to delte an Entry in this
    table gives me

    Fatal error: Call to undefined function: pma_dbi_try_query()
    in
    /var/www/phpMyAdmin/libraries/check_user_privileges.lib.php
    on line 16

    Here is the export of the Table:

    -- phpMyAdmin SQL Dump
    -- version 2.7.0-pl2
    -- http://www.phpmyadmin.net
    --
    -- Host: localhost
    -- Generation Time: Jan 04, 2006 at 09:47 AM
    -- Server version: 3.23.49
    -- PHP Version: 4.3.9
    --
    -- Database: `test`
    --

    -- --------------------------------------------------------

    --
    -- Table structure for table `test`
    --

    CREATE TABLE `test` (
    `ID` int(5) unsigned NOT NULL auto_increment,
    `Field0` varchar(255) NOT NULL default '',
    `Field1` varchar(255) NOT NULL default '',
    `Field2` varchar(255) NOT NULL default '',
    `Field3` varchar(50) NOT NULL default '',
    `Field4` varchar(20) NOT NULL default '',
    `Field5` varchar(20) NOT NULL default '',
    `Field6` char(2) NOT NULL default '',
    `Field7` varchar(255) NOT NULL default '',
    `Field8` varchar(255) NOT NULL default '',
    `Field9` varchar(255) NOT NULL default '',
    `Field10` varchar(255) NOT NULL default '',
    `Field11` varchar(255) NOT NULL default '',
    KEY `FilmID` (`ID`)
    ) TYPE=MyISAM AUTO_INCREMENT=3 ;

    --
    -- Dumping data for table `test`
    --

    INSERT INTO `test` VALUES (1, 'test1', '', '', '', '', '',
    '', '', '', '', '', '');
    INSERT INTO `test` VALUES (2, 'test2', '', '', '', '', '',
    '', '', '', '', '', '');

     
  • Marc Delisle

    Marc Delisle - 2006-01-10
    • assigned_to: lem9 --> nobody
     
  • Marc Delisle

    Marc Delisle - 2006-01-10
    • assigned_to: nobody --> lem9
     
  • Marc Delisle

    Marc Delisle - 2006-01-10

    Logged In: YES
    user_id=210714

    I can confirm this problem in 2.7.0-pl2, but I cannot
    reproduce it in the CVS version. In my case, it happens when
    a user has table-specific rights to a table, but no explicit
    rights to the db which contains this table.

    Please download the latest CVS snapshot at
    http://www.phpmyadmin.net/cvs and try it.

     
  • Dan

    Dan - 2006-01-11

    Logged In: YES
    user_id=1424834

    I also confirm this problem in a clean install of 2.7.0-pl2.
    In my case, I'm accessing a table as the root user (all
    privs), I did a "browse" of the table, and then I pressed
    the "edit" link to modify a record. I then get the error:

    Fatal error: Call to undefined function:
    pma_generate_common_url() in
    /...systempath.../phpMyAdmin/libraries/header_meta_style.inc.php
    on line 44

     
  • Marc Delisle

    Marc Delisle - 2006-01-11

    Logged In: YES
    user_id=210714

    wildwoods2, could you try with the latest CVS snapshot
    http://www.phpmyadmin.net/cvs

     
  • Dan

    Dan - 2006-01-11

    Logged In: YES
    user_id=1424834

    I downloaded CVS phpMyAdmin-20060110-053502 today and
    confirm that I can _not_ reproduce the error when using the
    CVS version.

     
  • Marc Delisle

    Marc Delisle - 2006-01-11
    • priority: 5 --> 1
    • status: open --> open-fixed
     
  • Marc Delisle

    Marc Delisle - 2006-01-11
    • summary: Call undefined:pma_generate_common_url() pma_dbi_try_query() --> (in 2.7.1) Call undefined:pma_generate_common_url()
     
  • meks

    meks - 2006-01-15

    Logged In: YES
    user_id=797013

    i can confirm this bug to be reproducable using 2.7.0-pl2
    and i can as well report that this bug seems to be fixed
    using the latest cvs snapshot. at the time of writing this
    was phpMyAdmin-20060114-053501.tar.bz2.

     
  • Marc Delisle

    Marc Delisle - 2006-03-06
    • status: open-fixed --> closed-fixed
     
  • Thierry

    Thierry - 2006-03-09

    Logged In: YES
    user_id=1358602

    I have the same problem using 2.7.0-pl2.
    Can you give me a patch to correct the bug or where I can
    find it?

     
  • Marc Delisle

    Marc Delisle - 2006-03-09

    Logged In: YES
    user_id=210714

    gassla, 2.7.0-pl2 is not the latest stable version. You can
    download 2.8.0.1 now.

     
  • Thierry

    Thierry - 2006-03-10

    Logged In: YES
    user_id=1358602

    lem9, I'm a Debian user and I'd like to send a patch to the
    maintainer for phpmyadmin the patch to correct quickly this
    bug in Debian sid .
    Thanks

     
  • Marc Delisle

    Marc Delisle - 2006-03-10

    Logged In: YES
    user_id=210714

    Sorry, but looking at this bug's history, there was no patch
    produced to fix it specifically. The bug existed in the 2.7
    series but not in the 2.8 series.

     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks