Install won't accept admin IP

Help
Autumn W
2008-06-05
2013-06-03
  • Autumn W

    Autumn W - 2008-06-05

    Hi there,

    I can't get past step two. In the config file, I insert the IP address as requested, between the quotes, and change the file name (removing .sample) and upload it to the conf directory. But when I hit reload, it just asks me to do it again. And AGAIN. And AGAIN. LOL

    I saw that a guy on here had the same problem, but didn't post a solution because it somehow just "worked itself out". Well, it ain't for me!

    Any suggestion would be appreciated.

    Note: I made sure there was no space after the ip address. Yes, I'm uploading to the correct folder. I always check for the stupidest mistakes first. *grin*

    Thanks!

     
    • Marc Carlucci

      Marc Carlucci - 2008-06-06

      hi,

      here are two things you can try:
      1. check your ip at http://whatismyip.com/
      2. check that the ip the server is getting is the correct one, to do so put the following into a file and upload it next to index.php:

      File check_ip.php:
      <?php echo '<pre>'; var_dump($_SERVER);

      then access it ( http://yourdomain.com/check_ip.php ) and check the value of REMOTE_ADDR

      This should give some indication why it isn't working.

      Marc Carlucci

       
    • Autumn W

      Autumn W - 2008-06-08

      Bizarre. I did both of those things, thanks, confirmed the IP address, changed it, uploaded it. I got to the page that said I needed to adjust file permissions. Did that (chmoded the right ones writable), then it bumped me back to the IP verification page again. I checked the config file - IP is correct.

      Basically, it's doing the exact same thing. Everything is uploaded correctly and the IP is correct but I'm still not able to get past that step in the installation.

      I'm about ready to give up on this script. I really wanted to take a look at it, but can't very well do so if it won't even install. :)

      Any other suggestions? TIA.

       
      • Marc Carlucci

        Marc Carlucci - 2008-06-09

        Has you said, it's strange. Could you let us know which hosting company you are using ?

        The last solution will be for you to do disable the install mode, by setting it to 0 in your config.ini.php , upload some pictures and try it out.
        If it's not working set the debug mode to 3 and re try.

        Hope it works for you

        Regards,
        Marc Carlucci

         
        • Autumn W

          Autumn W - 2008-06-09

          Thanks for the response.

          OK... even weirder. I disabled install mode (0), uploaded the changed config file, then tried to go to the index page. (phpgraphy/) It STILL redirects me to a new install!

          Question: Is there a particular NAME that the diirectory should have? I have it named "phpgraphy", all lowercase.

          This is just absolutely bizarre. It's like the changes that I'm uploading (to the config file) aren't being recognized. But when I view the config file on the server (through FTP - view) the changes are there!

          FYI - I have a dedicated server with Fastservers.net

          How in the world can the script not be recognizing changes I'm making to it and uploading? It tells me to do something and I do it, but then it ignores it! AGH!

          Any other ideas? (Knowing me, it's probably something really simple that I'm just missing. But I've been wracking my brain for days on this and still no solution!)

          Thanks!

           
    • Autumn W

      Autumn W - 2008-06-09

      Don't know if this helps, but there doesn't appear to be a log file created either. I look in my logs directory, and all there is is .htaccess

      During the initial attempt at installation, I got to the screen where it told me that I needed to change some permissions on directories. I changed the first two (out of four, I think) and hit refresh. This is when the problem started. It never took me back to the screen that told me about the other two directories that needed to be chmoded.

      Could this be the issue? What are the chmod settings necessary for each directory during installation? Could I be stuck in a loop where it would work properly if certain directories had the correct permissions set, but I can't see it BECAUSE the permissions aren't set correctly? (I know I'm reaching here, but I'm trying to figure out why that permissions page disappeared before I'd set them all properly!)

      :)

       
      • Marc Carlucci

        Marc Carlucci - 2008-06-09

        well the only thing I can think of is that there might be a proxy between the hosted server and your browser.

        Try doing a fresh install, and Reload clearing the cache of your browser http://en.wikipedia.org/wiki/Wikipedia:Bypass_your_cache
        You might want to try with different browser, Internet explorer and/or Firefox

        If that doesn't help try modifying the index.php adding some comment at the top : /* Blah blah */

        If you can, try from another internet connection.

        Thanks for your patience, I hope that you'll get your phpGraphy up & running !

        Marc Carlucci

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks