silhouette not showing

Help
tthdoc
2011-12-31
2013-05-30
  • tthdoc

    tthdoc - 2011-12-31

    I have never used silhouettes before and decided to start  using them where I don't have a photo of the person.  I changed the to allow silhouettes to yes  in the configuration file.  When I log out and log back in, no silhouettes are showing.  What else do I need to do to get them to show.  (and I guess should I decide I don't want it in the future, what else beside changing it to no do I need to do?) PGV 4.3.0.

    Thanks and Happy New Year to everyone.
    Doc

     
  • Stephen Arnold

    Stephen Arnold - 2011-12-31

    Maybe caching? Doc, when requesting help, can you supply a URL to your site? Seeing problems displayed on your hardware makes things a good deal easier to visualize.
    -Stephen

     
  • Gerry Kroll

    Gerry Kroll - 2012-01-01

    Yes, please post a URL so we can see for ourselves.

    If you don't want to publish your URL here, you can e-mail it to me:  gkroll at keldine dot ca

    If your site requires a login to view even dead people, you will, of course need to e-mail me the login credentials.

     
  • tthdoc

    tthdoc - 2012-01-01

    I did a search through all the files I had for PGV and did not see any images for a silhouette, so that may be the problem, unless I am just overlooking it.  Could you tell me what the file names are for them and what directory they should be in so I can see if they are there?  If I can find them and it still does not work, we can go from there.

    Thanks,
    Doc

     
  • Stephen Arnold

    Stephen Arnold - 2012-01-01

    Doc
    As I suggested offline, you may not have the images. These should be in the v4.3.0 download.
    In PGV, they appear under the general images directory,  ur PGV site/images/
    as silhouette_female.gif, silhouette_male.gif, silhouette_unknown.gif
    AND, they should also be within each of the theme image folders,  ur PGV site/themes/each-theme/images/
    as the same three gifs:  silhouette_female.gif, silhouette_male.gif, silhouette_unknown.gif
    -Stephen

     
  • Gerry Kroll

    Gerry Kroll - 2012-01-01

    Each theme's theme.php file also needs the following three entries:

    $PGV_IMAGES["default_image_M"]["other"] = "silhouette_male.gif";
    $PGV_IMAGES["default_image_F"]["other"] = "silhouette_female.gif";
    $PGV_IMAGES["default_image_U"]["other"] = "silhouette_unknown.gif";
    
     
  • tthdoc

    tthdoc - 2012-01-01

    Thanks, that was the problem.  I checked another theme image directory and they were there, but they were not there in the custom them image directory.  Copied them over and all is working fine now.

    Thanks again,
    Doc

     
  • Gerry Kroll

    Gerry Kroll - 2012-01-02

    When silhouettes were implemented, we were very careful to ensure that this new feature would not break custom themes.  I'm glad to see that this worked as intended.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks