PHVersion 4.2.4 errors under PHP 5.5.12

Help
impartit
2014-06-16
2014-07-06
  • impartit

    impartit - 2014-06-16

    With my current installed WAMPSERVER the PHP version is 5.5.12 which gives errors in PhpGedview 4.2.3 Specifically "Deprecated preg_replace(). the /e modifier is deprecated use preg_replace_callback instead". Line 440 in c:\wamp\www\familytree\includes\classes\class_gedcommrecord.php.

    Running "Google Chrome on Windows 7 32 bit on IBM T61".

    Can anyone help? Changing each occurence would be tiresome.

     
  • Stephen Arnold

    Stephen Arnold - 2014-06-17

    You can not use PGV 4.2.3 with PHP 5.5. You must be using PGV v4.3.
    While it that version is, at this time, compatible, it may be only a short time before you may not be able to use any PGV version with a modern version PHP.

     
  • oppiet30

    oppiet30 - 2014-07-03

    I have a fix for that error for pgv 4.2.4. But the rest still doesn't work.

     
  • Gerry Kroll

    Gerry Kroll - 2014-07-06

    Do as Stephen says: upgrade to version 4.3.0. This is also the "SVN" version. Download and upgrade instructions are contained in other Help posts.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks