Unable to set default gedcom

Help
Kipp
2011-03-12
2013-05-30
  • Kipp

    Kipp - 2011-03-12

    I cannot set the default gedcom.  When I change it with the drop down the page refreshes with the default gedcom unchanged.

    v4.2.3 on Windows
    index folder is writeable

     
  • Stephen Arnold

    Stephen Arnold - 2011-03-13

    Bug in 4.2.3 on GEDCOM selection, AND several serious security bugs. You should not be using v4.2.3, which is 15 months old. Since your platform supports 4.2.3, there is valid reason not to update to 4.2.4 (with patches).

     
  • Gerry Kroll

    Gerry Kroll - 2011-03-13

    You can also upgrade to the "SVN" version, which self-identifies as version 4.3.0.  It's really 4.2.4 with all of the patches, all in one package.

    The download location for the SVN package is given in a recent "Help" posting.  There's just one difference between the SVN package and the 4.2.4 version:  There's no "config.php" file.  Instead, there's "config.dist".  If you're doing a fresh install, you'll need to re-name this file to "config.php", because that's what the program is looking for.  If you're doing an upgrade, you can ignore this file.

    The upgrade procedure for 4.2.3 to 4.2.4 or 4.3.0 has been described lots of times.  The most recent example is in the "media" posting just below this one.

     
  • Gerry Kroll

    Gerry Kroll - 2011-03-16

    The main site hasn't been updated.  Thanks for pointing that out.

     
  • Kipp

    Kipp - 2011-04-12

    Okay, I have upgraded to v4.2.4 and I still cannot change the default gedcom.

     
  • Gerry Kroll

    Gerry Kroll - 2011-04-13

    Make sure the "config.php" file is writable.

    Sign in as Admin, and then access the Admin page.  Select the "Configuration" option.

    Since your site is already configured, the Install wizard will jump to Step 4 and open the "Site Configuration" set of options.  The page should start with the "Basic" tab.  Check the third option from the top.  This option determines whether GEDCOM switching should be permitted or not.

    After having corrected whatever options are set incorrectly, continue clicking the "Next" button until the configuration has been saved.

    When the "config.php" file has been updated, you can reset its permissions to read-only.  The permission should be 755, but on some operating systems you can get away with having this set to 644.

     
  • Kipp

    Kipp - 2011-04-20

    Okay, I checked all that exactly as you said.   I'm on a windows server so I cleared the read only attribute.  The configuration stated with the warning that the config was writeable.  The setting for "Allow GEDCOM switching" is and was already set to yes.  I went ahead through the config and saved the settings again.  I immediatly went to the admin and attempted to set the defailt gedcom and the setting would not take.  I defaulted back to the wrong gedcom.

     

Log in to post a comment.