Internal error while updating PGV_SCHEMA

  • Anonymous

    Anonymous - 2011-03-21

    Hello all,
    I'm trying to install (not update) the last version of phpgedview. At today I'm using the version 4.1.5.
    Now I'd like to upgrade it and I'm installing from the beginning the  4.2.4 on the same server.
    When I start step 2 I have this error:
    Internal error while updating PGV_SCHEMA_VERSION to 1

    I read some post ago ( that it could be a memory limit.
    I can't change my server limit (here is my php ver: I have yet tried to change to 50M the limit in config.php, but I still have the same error.
    The only support I ofund is in this post:

    Any other suggestion? TIA

  • Gerry Kroll

    Gerry Kroll - 2011-03-21

    PhpGedView was not able to create the phpgedview_site_setting database table.  phpgedview in this table name is whatever table name prefix you chose in the configuration.  This field should not be empty.

    This means that the userid you use to connect PhpgedView to your database does not have sufficient rights.  You need to contact your service provider for assistance.

  • Anonymous

    Anonymous - 2011-03-24

    The user has privileges, I enter in PhpMyAdmin and I can create tables as I want.
    Could anyone send me the SQL code to create site_setting_table, please?


  • Gerry Kroll

    Gerry Kroll - 2011-03-24

    You'll find the PHP script in includes/db_schema/db_schema_0_1.php

    The error message itself comes from the code in includes/classes/class_pgv_db.php lines 780 to 788.

    Can you confirm that the phpgedview_site_setting table exists (BEFORE you try to create it manually)?  If it exists, what's in it?

  • Anonymous

    Anonymous - 2011-04-01

    Well, I don't know how, but I solved. I tried to jump over step 6, to change manually the config.php, to came back to step 2….. I made a lot of confusion but finally I solved.

    Anyway, I think it was a memory problem, at the beginning the table phpgedview_site_setting couldn't be created by install process.

    Thanks to all

  • Gerry Kroll

    Gerry Kroll - 2011-04-01

    Thank you for letting us know that your problem has gone away.

    May people have no trouble setting up PhpGedView, but occasionally someone, like yourself, has a lot of problems. 

    Most of the time, the problems are caused by PGV not being allocated enough memory or by incorrect permissions either on the PGV scripts themselves or the data subdirectories.  Sometimes the problem is caused by incorrect PHP library version or by incorrect database version or by incorrect database connection information.

    Sometimes, also, the user has forgotten to create the database outside of PhpGedView.  You need to remember that PGV can only create tables in an already existing database.

    It would be nice to know exactly what caused your problems and what eventually resolved them.  I guess we'll never know.


Log in to post a comment.