Problems in import

  • miron

    miron - 2012-03-03

    I'm having problems importing a GEDCOM which imported fine before 4.2.3.
    After a while, I'm getting:
    ERROR 8: Undefined variable: gid
    0 Error occurred on line 713 of file functions_import.php in function import_record
    1 called from line 971 of file uploadgedcom.php

    and the import stops.
    Is there a way to see what is hapenning in the import process?

    I'm afraid I will have to revert to older PGV version since I'm not able to resolve this. Tried lowering the time limit, even imported a thinner GEDCOM version, without success.


  • Stephen Arnold

    Stephen Arnold - 2012-03-03

    AS noted in the change logs:

    - Fixed:  4.2.3 … un-def var gid when importing (fisharebest)

    You must have mixed files and failed to upload the newest ones or failed to overwrite the older ones. Too, you may have a corrupted file.

    We would NOT recommend you using the stable v 4.2.3. Instead, as posted here move than several times, use SVN v4.3 as there are many tweaks to the code and a few serious bug fixes.

  • miron

    miron - 2012-03-04

    Thanks Stephan,
    Should 4.2.4 resolve this?

  • miron

    miron - 2012-03-04

    I don't see v4.3 in the tags or in the branches. Should I pull the trunk?

  • miron

    miron - 2012-03-04

    Additional info: in 4.2.4 after numerous rounds of import, it seems like import is stuck. I went to check the DB and it seemed to be in a good shape (at least for indi and fam numbers). So i changed the gedcoms.php imported from false to true, and everything seems to be working ok. I will check further but maybe the problem is only that the importer is not showing the import end correctly?

  • Gerry Kroll

    Gerry Kroll - 2012-03-04

    PLEASE upgrade to 4.3.0 (the "SVN" version).  There have been MANY posts that recommend this version be used.  All of these posts tell you where to find this version.

    Try reading some of the recent Help posts, especially the one whose title begins with "Repost: …"

    There is no guarantee that the Import completed successfully if you did not get the proper messages about the Import. 

    The following information was posted in response to other Help requests about a stalled Import:

    During Import, PGV creates a backup GED that mirrors what's being imported into the GEDCOM.  The zero-level record in this file is the last person, family, source, etc. to be successfully imported into the database.  The next zero-level record in the input GEDCOM is where the problem lies.

  • miron

    miron - 2012-03-04

    That helped indeed. After I installed the SVN trunk version and tried the import again - it completed successfully and the quirks of the interrupted import disappeared.


Log in to post a comment.