Help save net neutrality! Learn more.
Close

Gedcom File Size is 392MB

Help
tnmtnmom
2012-04-03
2013-05-30
1 2 > >> (Page 1 of 2)
  • tnmtnmom

    tnmtnmom - 2012-04-03

    I have installed this and uploaded my wife's gedcom file to my server via ftp.  But  nothing is happening after saving configuration in admin panel.  She has been doing her tree for over 10 years and finally wants to get it on the web.
    Hope help is Aval.

    Thanks

     
  • Stephen Arnold

    Stephen Arnold - 2012-04-03

    Avai

    I have installed this

    You mean you have installed and have working PGV v4.3 ?

    uploaded my wife's gedcom file to my server via ftp

    You mean you did not use the local upload option? Regardless, HAVE YOU IMPORTED the GEDCOM?
    -Stephen

     
  • tnmtnmom

    tnmtnmom - 2012-04-03

    I could not use the local upload option as it is  ( Maximum upload size: 64M )

     
  • Stephen Arnold

    Stephen Arnold - 2012-04-03

    Avai
    The key word was 'regardless'. Did you IMPORT the gedcom yet?
    -Stephen

     
  • tnmtnmom

    tnmtnmom - 2012-04-03

    No, for the reason stated above.   I will try but….

     
  • tnmtnmom

    tnmtnmom - 2012-04-03

    While GEDCOM is being imported, I have another question…

    Without the gedcom imported, what should be displayed for an index page?

     
  • Stephen Arnold

    Stephen Arnold - 2012-04-03

    Nothing as there is no file to use to display anything. WIthout importing at least one, the program should default to the admin page.

     
  • Stephen Arnold

    Stephen Arnold - 2012-04-03

    No, for the reason stated above.

    Uh? One has nothing to do with the other. Have you raad the readme and/or the wiki on installation and setup?  I can't imagine a 392mb gedcom - it must be over 300,000 indi's, but again, regardless, even gedcom must be imported into the database for the program to work. Either via upload from your local machine, or if too large, by uploading directly to the index folder.
    -Stephen

     
  • tnmtnmom

    tnmtnmom - 2012-04-03

    Yes her GEDCOM is that large. Like I said, she has been doing this for over 10 years and has over 152,000 indi.    Yes I've read the readme and read the wiki.  

     
  • tnmtnmom

    tnmtnmom - 2012-04-04

    Well after 12 hours, importing did not work.

     
  • Gerry Kroll

    Gerry Kroll - 2012-04-04

    Please explain "did not work".  What happened?

    You didn't tell us what version of PGV you installed.  You should be using version 4.3 - the download and install instructions are in a Help topic whose title begins with "Repost: ".

    One thing: you're going to need a LOT of memory.  Let PGV use up to 256 Mb of memory.  If you can set it higher than that, do so.  This assumes, of course, that the PHP configuration of your server has its memory limit set that high.

    You're also going to need to increase the execution time limit to something like 5 minutes (300 seconds), and the Import time limit will need to be set slightly lower than that (about 290 seconds).  Again, the server's PHP configuration will need to be set accordingly.

     
  • tnmtnmom

    tnmtnmom - 2012-04-04

    PhpGedView 4.2.4

    256mb memory not a problem, but with a shared host execution and Import time is.  I was able to reduce the file size buy
    converting from FTW file to a ged extension.  file size is down to 68mb.  When I try to import it just runs and runs for hours and never imports.  I don't pretend to be a wiz as I was trying to do this for wife.

     
  • Gerry Kroll

    Gerry Kroll - 2012-04-04

    Well, yes!

    PGV will not import a Family Tree Maker file directly.  You have to export it to a GEDCOM.  What version of Family Tree Maker do you run?  You need to set the Export options correctly in Family Tree Maker, otherwise you will run into severe problems when you import.

    I would STRONGLY recommend that you start over again, and use the "SVN" version.  This is also called "version 4.3", depending on whio you talk to and when you talk to that person.

    You DO need to set the memory limit high - 256 Mb should be enough, and you also need to set the time limit higher.  Talk to your hosting company about what the maximums are that are allowed by their system. 

    You do NOT want to set your Import time limit to be hours long, and you also do NOT want it to be too short.  Somewhat less than 5 minutes should be enough.  This will break the Import up into smaller pieces.  The total import time will certainly be a couple of hours, but it will be broken up into smaller chunks.

    Let us know what version of FTM you have.

     
  • Stephen Arnold

    Stephen Arnold - 2012-04-04

    Avai
    256mb for a nearly 70mb file may not be enough, and having restrictions on your execution time is going to mean trying to do this in very, very small bites - about 10-15 second segments. I doubt you'll ever see the progress bar as it is reset with each restart.

    What format is used? ANSI or UTF-8. If the former, it may never succeed.  I would suggest you bundle (zip) the gedcom and send it to me or Jerry for review, import and export from PGV with a new zip. Or, you could skip the PGV route and go straight to webtrees which can handle the size much easier.  Finally, if you really want PGV - DO NOT USE 4.2.4 as we both suggested only 4.3.  There are serious import problems with 4.2.4.
    =Stephen

     
  • tnmtnmom

    tnmtnmom - 2012-04-04

    Hi all,

    1st off I want to say "Thank You"  for all the help and advice.  With all the info you have given me, I realized that a shared host
    would not be able to handle what I needed it to.   I just signed up for a mid size vps that should be online in 24 hours or so.

    I will start over on the vps with the 4.3 version.   I was able to get the file converted to a GETCOM.  

    I will let you know how I make out.

    Again to all A big Thank You!!

     
  • Gerry Kroll

    Gerry Kroll - 2012-04-05

    tnmtnmom:
    You didn't answer a very important question:

    What version of Family Tree Maker did you use to export your FTM file to a GEDCOM? 

    It's very important that the Export options in FTM are set correctly, otherwise you'll end up with a file that claims to be a GEDCOM (and actually looks like a GEDCOM) but that's still formatted incorrectly according to the GEDCOM standard.

     
  • tnmtnmom

    tnmtnmom - 2012-04-05

    I'm sorry, I didn't use Family Tree Maker to convert it to GEDCOM.   As wife has the latest FT Maker, I didn't want a chance of it not working, so I used "GenoPro" and had no problem with the conversion. 

    I must be blind as I cannot find a link for 4.3.   This old man just might need bigger coke bottle len's

     
  • Gerry Kroll

    Gerry Kroll - 2012-04-05

    tnmtnmom:

    Maybe you need to take your glasses off (I do)!

    The instructions for downloading and installing the "SVN" version are just below this Help topic post.  The title of the post begins with "Repost: Download "SVN".

    I would NOT attempt to use anything other than Family Tree Maker to create the GEDCOM.  FTM is the only program that is guaranteed to understand its internal database structure.

    For some versions of FTM (I use 2006 because I don't like the user interface for 2008 and 2011, which I also have):

    Open FTM, and click on the "File" menu option.
    In the popup menu, select "Export File" and then click on the "Entire File" option. 
    Select the destination folder for the exported file, or make note of where FTM wants to save.
    In the dropdown list of file types, select "GEDCOM (*.GED)"
    Change the output file name if necessary, but KEEP the ".GED" part.
    Click the "Save" button.
    Set these export options:
       - Destination: FTM
       - GEDCOM: Version 5.5
       - Character set: ANSI
       - Uncheck the "Indent records" option
       - Check the "Abbreviate tags" option
    Click the OK button.

     
  • tnmtnmom

    tnmtnmom - 2012-04-05

    Ok, got it installed, and am importing the new GEDCOM from an older version (2006) of FTW.  File size was 26mb, but I did notice that the max size for uploading was 2mb.  Regardless Its supposedly uploading. 

    What happens when upload finishes?  How long should I wait?

     
  • tnmtnmom

    tnmtnmom - 2012-04-05

    Waited 3 hours and nothing happened.   Closed the site, reopened.  Nothing but the folder

    Index of /

        cgi-bin/
        phpGedView/

     
  • Stephen Arnold

    Stephen Arnold - 2012-04-05

    Upload the file to your INDEX folder. Then navigate to the Manage Gedcoms and IMPORT the file, specifying the one you have previously uploaded. (Keep the name simple - no spaces, special characters, eg = smith.ged)

    Set the import time to about 30 seconds (I don't know the time you have for script action, but 5-10 seconds less than this figure).
    Depending on your CPU and memory, 26 mb should take about 20-30 minutes.  On my machine (using webtrees), I can import a 56mb file in about 15 minutes and on PGV about 1 hour.

    You should see a progress bar. It will refresh (be sure to select auto-restart, or whatever the terms are for auto-continue). When complete you can go to the index page (Welcome) and you'll see some stats and you can begin setting your personal preferences.
    -Stephen

     
  • Stephen Arnold

    Stephen Arnold - 2012-04-05

    If you are not successful this time, send me an admin access account (U.N - PW) and I'll take a look at your setup.
    Stephen

     
  • tnmtnmom

    tnmtnmom - 2012-04-05

    pm sent….

     
  • Gerry Kroll

    Gerry Kroll - 2012-04-05

    Two very important points:
    when you FTP the GEDCOM into the index folder, you need to set its permissions to 777 before you start PGV.

    Also, tell PGV to add an existing GEDCOM, and tell it just the file name you uploaded.  Do NOT tell it that the file lives in the index directory.  PGV will figure this out by itself.

     
1 2 > >> (Page 1 of 2)

Log in to post a comment.