#2866 Install Fails Config.php corrupt

v4.2.4
closed-invalid
None
5
2011-05-15
2011-05-06
Marx Rojas
No

I am trying to install v. 4.2.4 into XP for development, have PHP 5.3, MySQL 5.5. When I run the install it fails on step 6 where it saves the config.php file. After that I cannot access any file on the site, as they all return a 500 Internal server error on IE6 and a blank page on Firefox.

Version 4.2.1 works fine.

Also, I am attaching the config.php file it generates. It seems corrupt, as some of the single quotes are missing. Even when I try to fix the file by manually adding the missing quotes, the install still fails.

Finally I get the same result when I try to do either an upgrade or from install from scratch using a new mySQL DB.

Discussion

  • Marx Rojas

    Marx Rojas - 2011-05-06
     
  • Gerry Kroll

    Gerry Kroll - 2011-05-07

    Did you check the config.dist file that you downloaded? Is this file corrupt too?

    This might be problem with the server's "magic quotes" configuration.

    magic_quotes_gpc should be ON
    magic_quotes_runtime should be OFF
    magic_quotes_sybase should be OFF

     
  • Marx Rojas

    Marx Rojas - 2011-05-09

    Cool, this fixed the issue.

    Thanks!

     
  • Gerry Kroll

    Gerry Kroll - 2011-05-15
    • assigned_to: nobody --> canajun2eh
    • status: open --> closed-invalid
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks