#27 PgD2 doesn't start anymore

closed-fixed
5
2011-05-30
2011-02-14
Mind And Go
No

Dear Luigi,

I just update my distro and since that operation, pgdesigner doesn't start anymore. I recompiled it and nothing is better.
The logs are as follows :
kdeinit: Got EXEC_NEW 'kconf_update' from launcher.
kio (KLauncher): kconf_update (pid 7613) up and running.
kdeinit: PID 7613 terminated.
DCOP: new daemon kded
DCOP: unregister 'anonymous-7610'
kdeinit: PID 7610 terminated.
DCOP: register '2.0-alpha-7602' -> number of clients is now 1
Error: Value type error!
Code: -1
Class: pgClassItem
Where: pgClassItem.Value_Write.50
Trace: pgClassItem.Value_Write.50
Trace: pgClassIntegerArray.fromString.32
Trace: pgConfig._load.303
Trace: pgConfig.Load.273
Trace: pgApplication._initializeConfig.219
Trace: pgApplication._initialize.135
Trace: pgApplication._runApplication.68
Trace: pgApplication.Run.63
Trace: pgDesigner.Main.13

I think that there's an issue with kde.
Thanks for your help

Discussion

  • Carlotto Luigi

    Carlotto Luigi - 2011-02-14

    Indeed, it seems a problem with kde.
    The version of Gambas2 is as indicated in the ChangeLog? (2.22.0)
    What version of kde? My version is 4.5.5.
    This is the latest version of pgDesigner from sf.net svn repository? (2.0.0-alpha-175 796)
    In addition, there may be some other problem with other libraries, but when I could not tell which ...
    As usual, on my computer everything works as it should ... :-)

    Let me know the versions (kde, gambas2, etc..), and let's understand something ...

     
  • Carlotto Luigi

    Carlotto Luigi - 2011-02-14
    • assigned_to: nobody --> md9327
     
  • Mind And Go

    Mind And Go - 2011-04-04

    Hy luigi,

    I'v' checked the differents versions of my laptop :
    ***
    kde4-config -v
    Qt : 4.5.3
    KDE : 4.3.5 (KDE 4.3.5)
    kde4-config : 1.0
    ***
    Gambas 2.20
    ***

    Regarding to your comment, I installed gambas 2.22, checked out the latest svn, compiled it and I have now the following error:
    Error: Value type error!
    Code: -1
    Class: pgClassItem
    Where: pgClassItem.Value_Write.50
    Trace: pgClassItem.Value_Write.50
    Trace: pgClassIntegerArray.fromString.32
    Trace: pgConfig._load.304
    Trace: pgConfig.Load.274
    Trace: pgApplication._initializeConfig.222
    Trace: pgApplication._initialize.138
    Trace: pgApplication._runApplication.68
    Trace: pgApplication.Run.63
    Trace: pgDesigner.Main.13

    Sorry for that,

    hope it could help

     
  • Nobody/Anonymous

    Gambas2 makes use of KDE 3, and KDE4 is ignored.

    Anyway I look at the error.

     
  • Mind And Go

    Mind And Go - 2011-04-09

    Hy luigi,

    I've checked my packages and work with :
    libkde3support4 - Bibliothèque de base KDE4​ 
    KDE 4 core library.
    Details:
    Version : 4.3.5-0.25mdv2010.0
    Version actuellement installée : 4.3.5-0.25mdv2010.0

    Hope it can help

     
  • Mind And Go

    Mind And Go - 2011-05-05

    Dear luigi,

    I've checked out your 177 release, update my mandriva 2010 with latest KDE packages and recompile everynthing even Gambas.
    Unfortunately, it doesn't solved my issue.

    On the other side, There is no problem for opening/compile the 1.x release. Maybe it could help
    Regards

     
  • Mind And Go

    Mind And Go - 2011-05-06

    Dear luigi,

    I observed some movements in your development.
    I'm wondering if you have an idea of the origin of my issue. The fact that gambas compile and execute correctly the 1.x release could be a clue, don't you think?

    Regards,

     
  • Carlotto Luigi

    Carlotto Luigi - 2011-05-07

    In my computer I get the KDE version 4.6.2, but also kdelibs3-3.5.10.
    Currently pgDesigner is also used by other people, but nobody has reported anomalies.
    Try to install the KDE3 libraries (see first line), because it is likely that the different version may somehow affect the compilation and execution.
    I unfortunately have no way to verify the error, unless you create a virtual environment, but should I install the same packages that you have on your system.
    I remind you that now is filled with pgDesigner2 Gambas-2.23.0.
    Let me know ...

     
  • Carlotto Luigi

    Carlotto Luigi - 2011-05-07

    You can send me (on my private email) the configuration file pgdesigner2.conf?
    Let me know if there are any incorrect, they can cause problems.

     
  • Mind And Go

    Mind And Go - 2011-05-08

    Dear Luigi,

    I updated the 191 release and delete the temporary file.
    Regarding to this problem, everything is fine now.

    Regards

     
  • Mind And Go

    Mind And Go - 2011-05-08
    • status: open --> open-fixed
     
  • Mind And Go

    Mind And Go - 2011-05-30
    • status: open-fixed --> closed-fixed
     
  • Mind And Go

    Mind And Go - 2011-05-30

    DEAR, DEAR Luigi,

    I'm happy to inform you that this annoying and almost terrific bug is now solved!
    The problem was really in the encoding.
    I remember that I had somethinh similar with synfig.org.
    So how I get out of this :
    I only use a command line with "export LANGUAGE=en_GB:en; " befor the path of pgDesigner.
    Thanks to this, everything is fine now.

    Regards

     

Log in to post a comment.