Database import

  • Andres

    Andres - 2014-07-30


    We are using the standalone version for a couple of months and I am trying to update to the professional.
    I am now using the ProjectForge-force-SSL-5.4.war with apache-tomcat-6.0.41. But I got stuck on the import function.
    The import stops at the point it starts importing the invoices. With this error :

    T=[2014-07-30 09:09:24,217]
    L=[ WARN]
    M=[SQL Error: -177, SQLState: 23000]
    T=[2014-07-30 09:09:24,218]
    M=[Integrity constraint violation - no parent SYS_FK_171 table: T_FIBU_KONTO in statement [insert into t_fibu_rechnung (pk, created, deleted,

    Could you help me with this ?

  • Kai Reinhard

    Kai Reinhard - 2014-08-18

    Hi, sorry for not responding earlier. Please check that you use the same ProjectForge version in both systems (the export file must match). If not, please update first. We can't reproduce the error. We may offer you, that you may send us your database files on a secret way and we will help you with the migration. Please let us know if you prefer this way (free of charge) and please send us a contact e-mail address.

  • Andres

    Andres - 2014-08-22


    Thanks for the response and offer. I have to discuss your offer before I can send it.
    In the mean while, I tried the same version and the war export from the standalone install.
    But unfortunately it gives the same results.

    I also tried to find out what the error is.
    What I think the problem is that the KONTO_ID in the t_fibu_rechnung is a join to the t_fibu_konto table.
    It is as if the error claims that the KONTO_ID of the record the import is trying to insert does not exist.
    And this is true, the records of the t_fibu_konto are not inserted yet.

    If I delete the KONTO_ID reference just for debugging in the XML import file the problem is solved.

    The same error then appears on inserting the t_fibu_eingangsrechnung with the join KONTO_ID.
    Solving this, another error shows up in the t_fibu_employee_salary table with the EMPLOYEE_ID.
    The same at inserting t_hr_planning_entry with PLANNING_FK.
    Here I stoped editing the XML file because I don't think it's wise to edit the file that much.

    I don't know if the import function checks records of these joins but if this is the case then the right order of inserting records and tables is necessary.

    I'm no expert on this but I hope this information can help solving the issue.


    Last edit: Andres 2014-08-22
  • Kai Reinhard

    Kai Reinhard - 2014-08-22

    Thanks, we created test data and yes, we may reproduce this bug. We'll keep you informed.

  • Kai Reinhard

    Kai Reinhard - 2014-09-04

    This is now a known issue and we need to fix it with the next release (refactoring the Hibernate-Export). We made an hot fix for you for the current release 5.4. We may deliver you a new war-file which you may use inside your new Tomcat installation. Would this be feasible for you?

  • Andres

    Andres - 2014-09-08

    Thanks for the effort and support.
    Sounds like a good solution.
    I am eager to try it.
    Is it possible to do this for the SSL version?

    Last edit: Andres 2014-09-09

Log in to post a comment.