Hi,
 
Could be that I broke this when upping the _WIN32_IE constant to 0x0501. If you put that back to 0x0400 does it work again?
 
Steve
-----Original Message-----
From: perl-win32-gui-users-admin@lists.sourceforge.net [mailto:perl-win32-gui-users-admin@lists.sourceforge.net]On Behalf Of Laurent ROCHER
Sent: 25 February 2004 19:02
To: ramy@mehtag.com; perl-win32-gui-users@lists.sourceforge.net
Subject: Re: [perl-win32-gui-users] Anyone help?

Hi,
 
    Same problem for me. It's a problem of not up to date include file. 
    For correct problem, i have tested those 3 methods.
    [RED = remove    BLUE = Add ]
 
    1) Small change in Win32-GUI source but warming messag.
 
        edit GUI.h and add this line :
        #define  WIN32_LEAN_AND_MEAN
        #define _WIN32_IE 0x0501
        #define _WIN32_WINNT 0x0400
        #define WINVER 0x0501
   
    Now it's work, but you have a warming message.
 
    2) Hack your default Windows.h header in include directory
 
#ifndef WINVER
#define WINVER 0x0400 0x0501
#else 
#if defined(_WIN32_WINNT) && (WINVER < 0x0400) && (_WIN32_WINNT > 0x0400)
#error WINVER setting conflicts with _WIN32_WINNT setting
#endif
#endif
 
#if(WINVER >= 0x0500)
#pragma message ("")
#pragma message ("NOTE: WINVER has been defined as 0x0500 or greater which enables")
#pragma message ("Windows NT 5.0 and Windows 98 features. When these headers were released,")
#pragma message ("Windows NT 5.0 beta 1 and Windows 98 beta 2.1 were the current versions.")
#pragma message ("")
#pragma message ("For this release when WINVER is defined as 0x0500 or greater, you can only")
#pragma message ("build beta or test applications.  To build a retail application,")
#pragma message ("set WINVER to 0x0400 or visit
http://www.microsoft.com/msdn/sdk")
#pragma message ("to see if retail Windows NT 5.0 or Windows 98 headers are available.")
#pragma message ("")
#pragma message ("See the SDK release notes for more information.")
#pragma message ("")
#endif
 
    This force default WINVER and remove warning message.   
    It's probably not very safe if you use VC for other building.
 
    3) You need to download and install last microsoft SDK.
 
      see: http://www.microsoft.com/msdownload/platformsdk/sdkupdate/default.htm
      You need core SDK. It's a huge download.
 
Laurent.

I downloaded the updated files  and tried to build under Windows 2000
but I am getting the error below. Any help would be appreciated.
It would be nicer if the new updated version can be packed and update
the version number. I remember also I installed before the binary version
and was unable to build  from the source. I have VC6 on the computer.

GUI.xs(2031) : warning C4101: 'targ' : unreferenced local variable
GUI.xs(2289) : error C2065: 'WINDOWINFO' : undeclared identifier
GUI.xs(2289) : error C2146: syntax error : missing ';' before identifier
'pwi'
GUI.xs(2289) : error C2065: 'pwi' : undeclared identifier
...
NMAKE : fatal error U1077: 'cl' : return code '0x2'
Stop.

Ramy