Linux Install

  • infamouswhiteknight

    I can't upgrade boot libraries to 1.45 as requested.  Well, I probably could, but not with the package manager and I am reluctant to do it manually…any suggestions for a way to get around this?

  • - 2011-08-15

    It depends on the exact versions of Boost and GCC in your distribution. Pentobi version 0.1 can be compiled with certain older versions of Boost but some versions of Boost do not work in combination with some versions of GCC if features of the coming C++ standard are enabled (as required by Pentobi).

    For example, the combination Boost 1.40/GCC 4.4 from Ubuntu 10.04LTS works. In this case, simply change the Boost version in the line "find_package(Boost …" in the file CMakeLists.txt and maybe also add the Boost version in the line "set(Boost_ADDITIONAL_VERSIONS …"

    Unfortunatly, the combination Boost 1.42/GCC 4.5 from the current Ubuntu 11.04 does not work. In this case, your only options are to wait for Ubuntu 11.10 or compile Boost yourself.

    Even if you are (understandably) reluctant to compile Boost yourself, here is what I did on Ubuntu 11.04:

    1. Download boost_1_45_0.tar.bz2 from (newer versions should also be fine but the steps for compiling boost may be different), extract it and change into the directory boost_1_45_0.

    2. Chose a private directory for installation (I chose not to do a system-wide installation in /usr/local), let's call it my_boost_1_45_directory. Then run the commands:

      ./ -prefix=my_boost_1_45_directory
      ./bjam install

    Compilation of Boost can take a long time depending on how fast your computer is (up to several hours).

    3. Change into the directory pentobi-0.1 and run

      rm -f CMakeCache.txt
      cmake -DBOOST_ROOT=my_boost_1_45_directory \
        -DBOOST_LIBRARYDIR=my_boost_1_45_directory/lib \
        -DBoost_NO_SYSTEM_PATHS=1 -DBoost_USE_STATIC_LIBS=1 .

    Then continue as normal with

      sudo make install
      sudo make post-install

  • infamouswhiteknight

    This solution no longer works for the new version of pentobi (1.0).  And once again, files created with newer pentobi can't be read on older versions :(

  • - 2012-01-14

    I'm not sure if you expect me to answer this since your message contains no questions, only statements. But without you providing any information about how the compilation fails or what the error messages are, and without me being clairvoyant, there is not much I can do to help you with this problem anyway.

    As for the change in the file format: unfortunately it is not always possible to provide forward compatibility, otherwise you would never be able to fix mistakes or add new incompatible features. I know that it is annoying to makes such changes and I will try to keep them to a minimum, but please note that before version 1.0, Pentobi was clearly marked as being in beta development status. I also tried hard to make the software backward-compatible, Pentobi 1.0 should be able to read files written by any previous version. So if you want to be able to read files written by newer versions, my advice is to upgrade Pentobi to the current version.

  • infamouswhiteknight

    The reason I posted that issue was because I was trying to do just what your advice said, and upgrade pentobi to the current version.  Of course I understand that changes need to be made, and that forward-compatibility is not always possible, and I'm sorry that I didn't give more clarification about what the problem was, I am still a bit new to Boost, and was unsure what the relevant portions of the very long output were.  I was hoping that maybe there was some change in boost that you might have known about that prevented it from working, but I guess that was not the case. 

    Anyway, for now this isn't a problem for me as I did a fresh system install (for other reasons), and then was able to upgrade boost as needed, so the newest version is working fine for me now.  Thanks.

  • infamouswhiteknight

    Once again I am having trouble installing pentobi, and was wondering if anyone here could help me:

    I am trying to install pentobi 1.0 on a fresh linux mint install - the processor on the computer I'm using is 32bit, so I can't use the convenient .deb file.  I (believe that I) have all the boost issues sorted out (by following the instructions in the earlier post in this thread), but am having a problem with QT.  When I run cmake . I am getting an error that I can't figure out how to fix.  I have included the error below.

    CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
    Call Stack (most recent call first):
      /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
      /usr/share/cmake-2.8/Modules/FindQt4.cmake:1162 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
      CMakeLists.txt:88 (find_package)

    Any help would be appreciated!

  • - 2012-02-27

    The key sentence in the error message is "Could NOT find Qt4". It means that Qt4 was not found. As mentioned in Pentobi's INSTALL file, the (development version of the) Qt4 libraries are required for compiling Pentobi. The package name to install on Ubuntu 11.10 is "libqt4-dev". If you used Linux Mint 12, it should be the same name because it Linux Mint 12 is based on Ubuntu 11.10.

    On Ubuntu 11.10, it is not necessary to compile the Boost libraries yourself, the version from the package repository (package name "libboost-all-dev") should work. Again, this should also be true for Linux Mint 12, but I haven't tested it myself.

    Actually, the Debian package that is downloadable from Pentobi's Sourceforge site was prepared for Ubuntu 11.10 and should also work on Linux Mint 12. What error messages did you get when trying to install it? Or did you install an older version of Linux Mint?

  • infamouswhiteknight

    Thanks for your quick reply!
    About Qt4 - I understood that I couldn't find it, but I didn't know you could get it from the repository - I had tried to download and install it myself, but clearly I failed.  I have now used the repository to install qt4 and boost, and was able to install the source code.
    As for the Debian package - it is for 64 bit linux, but as I mentioned the computer I was installing on only has 32 bit architecture.  Just for fun I tried to open that package with the installer, but I got this message:

    Status: Error: Wrong architecture 'amd64'.

    Also, while I was able to install from the source code, the post-install command didn't work and returned the following output:

    make: update-desktop-database: Command not found
    make: ***  Error 127
    make: ***  Error 2
    make: ***  Error 2
    make: ***  Error 2

    It doesn't prevent me from using the program (or cause any problems at all as far as I can tell), but I thought it would be good for me to mention.

  • - 2012-02-29

    The missing update-desktop-database is a problem. It could have the effect that Pentobi's entry is not visible in the desktop menu, that you cannot click on blksgf files in a local file browser to open them with Pentobi or that no previews for blksgf files are visible in the browser.

    Pentobi's "make install" installs a file describing the new desktop menu entry but it still needs to tell the system that the desktop menu has to be updated. Calling update-desktop-database is the usual cross-distribution method to do this. You can get this command by installing the package "desktop-file-utils" from the repository. I'm a bit surprised that this package is not installed by default in Linux Mint. The failure will also have the effect that the following command (update-mime-database) is not executed, which updates the MIME database after Pentobi installed a file describing the blksgf file type.

    It might be that things start suddenly working later if the desktop menu and MIME databases are updated for other reasons, maybe after you install or remove some package from the repository that triggers an update but I am not sure about this because by default, Pentobi's "make install" installs these files to /usr/local and packages from the repository are installed in /usr.

  • infamouswhiteknight

    Ah, you were right of course about the no desktop menu item and no file association.  The desktop menu item got fixed (without running any commands) after a reboot, so I guess that in mint that particular database updates automatically on startup or something.  For the file associations, I needed to run the update-mime-database command manually, passing it the location to look at inside of /usr/local/….  Anyway, it all seems to be working now, thanks for all the help!

  • infamouswhiteknight

    I just tried to install 1.1 on a fresh mint install.  Everything worked except the post-install command still gives errors.  The desktop menu icon still shows up after a reboot, but unlike with 1.0 I wasn't able to get the update-mime-database command to work. 
    I ran update-mime-database /usr/local/share/mime, which returned no errors (it returned nothing at all) but the file associations are still not working.  Any help would be appreciated.

  • infamouswhiteknight

    Scratch that, it started working, it just took another reboot after the update command.

  • - 2012-03-28

    I think the reboot was necessary for me too after the first installation before the MIME registration showed any effect (I am using Ubuntu 11.10). If someone can explain why this is so, I would be interested to know.

    The missing update-desktop-database on your Linux Mint seems to be not critical if the entry in the desktop menu appears anyway. In the next Pentobi release, "make post-install" will simply execute all commands even if some of them fail.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks