add fallback to pysqlite2 (no sqlite3 in python2.4)