debian gpg public key

  • bobama

    bobama - 2012-11-19

    I tried to install deb package form this repository:

    deb wheezy main
    deb-src wheezy main

    but i get GPG error on apt-get update: "the public key is not available".
    Probably I'm just blind - but I just can't find this gpg key anywhere. I found C0145138 but it doesn't work - same error.

  • jre-phoenix

    jre-phoenix - 2012-11-19

    You need to let apt know about it:

    gpg --keyserver --recv-keys C0145138
    gpg --export --armor C0145138 | sudo apt-key add -

  • bobama

    bobama - 2012-11-19

    ok ty.
    People behind a firewall need also to make sure that the port 11371 is open otherwise it will be impossible to import the key from the keyserver.
    Alternatively they can replace:

    gpg --keyserver --recv-keys C0145138


    gpg --keyserver hkp:// --recv-keys C0145138

    Last edit: bobama 2012-11-19

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks