#310 Debian dependencies too strict (debhelper)


In trying to compile pgl 2.0.3 using 'debuild' on a Debian/stable (lenny) system I got the error:

dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 7.0.50~)
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.

just doing 'debian/rules binary' instead resulted in the compilation and build of *.deb files working, as does the suggested 'debuild -d' to ignore dependencies.


  • jre-phoenix

    jre-phoenix - 2010-09-13

    I added this dependency for the override_... targets in debian/rules. So I added that dependency according to the debhelper documentation. And I just verified in the debhelper changelog that they were introduced in 7.0.50.

    Please verify if you have these files in your pglcmd package (dpkg -L pglcmd):

    Currently handling these files is all I need the override targets for. But that will change in the future.

    I guess you have installed debhelper 7.0.15!?

  • Athanasius

    Athanasius - 2010-09-13

    Looking closer I do indeed have debhelper 7.0.15 installed:

    18:29:06 0$ aptitude show debhelper
    Package: debhelper
    State: installed
    Automatically installed: no
    Version: 7.0.15

    BUT, look more closely at the error:

    dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 7.0.50~)

    18:30:47 0$ grep -r debhelper debian/
    debian/pglcmd.config:# generated by other debhelper scripts.
    debian/control:Build-Depends: debhelper (>= 7.0.50~),

    Stray tilde ?

    18:32:37 0$ dpkg -L pglcmd | grep '/etc/cron.daily/pglcmd|/etc/network/if-up.d/pglcmd|/etc/init.d/pgl|/etc/logrotate.d/pglcmd'
    18:32:58 0$

    And I guess this would be exactly why it fail to stop/start the service on install too.

  • Athanasius

    Athanasius - 2010-09-13

    Hang on, I'm blind, I have 7.0.<FIFTEEN>, your build-depends is after .<FIFTY>~

    http://packages.debian.org/lenny/debhelper confirms that 7.0.15 is the current stable version.

    Confusingly testing has 8.0.0 (same in unstable).

    And even backports.debian.org is on 8.0.0~bpo50+2

    Where did you get your 7.0.50~ from ?

  • SourceForge Robot

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

  • jre-phoenix

    jre-phoenix - 2010-10-20

    Just to bring this issue to a clean end (and then finally working again on the FORWARD issues reported by you):
    "7.0.50~" is from the debconf documentation. And as we've confirmed in the other bug, we really need this version (or newer). So in Lenny you should use backports.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks