#302 [PATCH] Make PDL::flat work under perl 5.16

critical
closed-accepted
nobody
core (120)
5
2012-05-20
2012-04-15
No

This is just a pointer to the real bug report on RT: https://rt.cpan.org/Public/Bug/Display.html?id=76577

Discussion

  • Chris Marshall

    Chris Marshall - 2012-04-15

    I don't believe that reshape can be used to
    extend a pdl (which is what the problem code
    appears to be doing). As such, the failing
    test may be more correct. Perhaps we should
    add a check for this.

    Given that the behavior will change with the
    release of 5.16, this will need to be sorted out.

     
  • Chris Marshall

    Chris Marshall - 2012-04-15
    • labels: --> core
     
  • David Mertens

    David Mertens - 2012-05-07

    Bug fixed in Git.
    Thanks for reporting the problem!

     
  • David Mertens

    David Mertens - 2012-05-07

    Fixed with commit 0c11c45

     
  • Slaven Rezic

    Slaven Rezic - 2012-05-12

    Note: the first release candidate for perl 5.16.0 is already available, and the real release will happen in a week or so.

     
  • Chris Marshall

    Chris Marshall - 2012-05-14
    • status: open --> pending-accepted
     
  • Chris Marshall

    Chris Marshall - 2012-05-14

    Patch has been accepted and applied to PDL git. Ticket is marked pending to close by default unless additional problems occur.

     
  • Chris Marshall

    Chris Marshall - 2012-05-20

    Bug fixed in Git.
    Thanks for reporting the problem!

     
  • Chris Marshall

    Chris Marshall - 2012-05-20
    • milestone: --> critical
    • status: pending-accepted --> closed-accepted
     

Log in to post a comment.