#301 t/gd_oo_tests.t fails for AMD64

critical
closed-fixed
nobody
other (94)
1
2013-07-06
2012-04-15
No

Opening a ticket to track the multiple fails from CPAN Testers
for the PDL-2.4.10_003 release. All the fails for this test were
on amd64 platforms and OS freebsd version 9.0 and openbsd
version 5.0.

Of the reports with PASS (including t/gd_oo_tests.t) there
were some amd64 platforms but the archname *never*
included amd64. E.g.:

Bad platforms:
6 osname=freebsd, osvers=9.0-release, archname=amd64-freebsd
8 osname=freebsd, osvers=9.0-release, archname=amd64-freebsd-thread-multi
5 osname=openbsd, osvers=5.0, archname=OpenBSD.amd64-openbsd
8 osname=openbsd, osvers=5.0, archname=OpenBSD.amd64-openbsd-thread-multi

Good platforms (with either BSD or AMD64 in the osname= line):
1 osname=freebsd, osvers=8.2-release, archname=i386-freebsd
2 osname=freebsd, osvers=8.2-release, archname=i386-freebsd-64int
3 osname=freebsd, osvers=8.2-release, archname=i386-freebsd-thread-multi
3 osname=freebsd, osvers=8.2-release, archname=i386-freebsd-thread-multi-64int
5 osname=gnukfreebsd, osvers=8.1-1-amd64, archname=x86_64-gnukfreebsd
4 osname=gnukfreebsd, osvers=8.1-1-amd64, archname=x86_64-gnukfreebsd-thread-multi
2 osname=linux, osvers=2.6.18-4-xen-amd64, archname=x86_64-linux-thread-multi
1 osname=linux, osvers=3.2.0-2-amd64, archname=x86_64-linux-thread-multi
5 osname=openbsd, osvers=5.0, archname=OpenBSD.i386-openbsd
5 osname=openbsd, osvers=5.0, archname=OpenBSD.i386-openbsd-64int
3 osname=openbsd, osvers=5.0, archname=OpenBSD.i386-openbsd-thread-multi
4 osname=openbsd, osvers=5.0, archname=OpenBSD.i386-openbsd-thread-multi-64int

Discussion

  • Chris Marshall

    Chris Marshall - 2012-07-07

    Re-enabled these tests for git and CPAN developer releases.

     
  • Chris Marshall

    Chris Marshall - 2012-10-19
    • milestone: --> 100444
    • status: open --> closed-out-of-date
     
  • Chris Marshall

    Chris Marshall - 2012-10-19

    Closing this ticket as the problem reports are no longer
    being generated for PDL-2.4.11. This may have been a
    platform/system bug and not one from PDL.

     
  • Chris Marshall

    Chris Marshall - 2013-01-18

    Marking the gd_oo_tests.t as TODO with the hopes of tracking down the specific problem.

     
  • Chris Marshall

    Chris Marshall - 2013-01-18
    • assigned_to: juddtaylor --> nobody
    • priority: 5 --> 7
    • milestone: 100444 -->
    • status: closed-out-of-date --> open-accepted
     
  • Chris Marshall

    Chris Marshall - 2013-01-24

    For the upcoming PDL-2.4.12 release, the failing tests will be skipped if the AUTOMATED_TESTING variable is set. Otherwise, the tests will be run---and most likely fail for BSD OSes on AMD64 platforms. Presumably, the user in the non-automated case could determine whether or not a single test file failure of t/gd_oo_tests.t warrants override for install in spite of the fail.

    Ideally, if they can reproduce the problem, I invite them to help debug the problem. Marking this as priority 1 since no actual users have reported the problem and the conditional skip will prevent massive PDL CPAN Tester failures for all BSD+AMD64 platforms.

     
  • Chris Marshall

    Chris Marshall - 2013-01-24
    • priority: 7 --> 1
     
  • Derek Lamb

    Derek Lamb - 2013-03-01

    This may be fixed with commit 7bbab7. Please check, and if it works we can un-TODO the gd_oo_tests and see if the BSD AMD64 testers can pass it now.

     
  • Chris Marshall

    Chris Marshall - 2013-07-06

    Problem appears to be resolved. Closing this ticket.

     
  • Chris Marshall

    Chris Marshall - 2013-07-06
    • status: open-accepted --> closed-fixed
    • Group: --> critical
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks