#13 Can only import one document (running on Windows)

closed-invalid
nobody
None
5
2010-10-07
2010-07-05
No

If I try to import a second pdf either by drag-and-drop or by the import button, nothing happens except command line messages:

Traceback (most recent call last):
File "C:\Python26\Lib\site-packages\pdfshuffler.py", line 513, in on_action_add_doc_activate
self.add_pdf_pages(filename)
File "C:\Python26\Lib\site-packages\pdfshuffler.py", line 336, in add_pdf_pages
os.path.samefile(filename, it_pdfdoc.filename) and \ AttributeError: 'module' object has no attribute 'samefile'

I don't know if this message is related:
C:\Python26\Lib\site-packages\pyPdf\pdf.py:52: DeprecationWarning: the sets module is deprecated
from sets import ImmutableSet

Discussion

  • Alister Hood

    Alister Hood - 2010-07-05

    It's possible that this problem is caused by one of the workarounds for the other bugs I've posted - I don't know. Or maybe something is wrong with my Python setup or something? Let me know if you think there is.

     
  • Alister Hood

    Alister Hood - 2010-07-09

    OK, I've found the fix for that:

    1. Delete `os.path.` from this line:
    os.path.samefile(filename, it_pdfdoc.filename) and \

    2. And add this code near the beginning:

    try:
    from os.path import samefile
    except:
    samefile = lambda x, y: os.path.normpath(x)==os.path.normpath(y)

     
  • logari81

    logari81 - 2010-07-14
    • status: open --> closed
     
  • logari81

    logari81 - 2010-07-14

    There is no intention to support Windows. PDFShuffler is developed for POSIX systems.

     
  • logari81

    logari81 - 2010-10-07
    • status: closed --> closed-invalid
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks