How do I enable PCMCIA for kernel?

pirwra
2005-10-25
2013-04-08
  • pirwra
    pirwra
    2005-10-25

    Hi!

    I have never used Linux before and am trying to install a Wireless PCMCIA Sparklan WL-311F on a Travelmate 2200 running Suse 9.3.

    I have downloaded and unpacked pcmcia-cs-3.2.4 and tried to run make config. Then this error message turns up:

    2.5.0 and later kernels require that PCMCIA be configured in the    kernel source tree.  To fix, reconfigure and rebuild your
        kernel with PCMCIA enabled.

    Where can I do this? I've seen on this forum that many people have a file called .config, I dont. How do I enable PCMCIA?

    The config files I have is config.mk config.in and config.new and I have no idea what to do.

    /pir

     
    • You have to have your kernel source ( it can be installed from your Suse CD or downloaded from www.kernel.org). It should be in /usr/src/linux directory. Then you cd to this directory and you do
      make menuconfig
      where you can enable PCMCIA support. After exiting menuconfig, the file .config you mentioned will be created. After that you have to recompile your kernel (you can find info how to do it on Google)

       
    • David Hinds
      David Hinds
      2005-10-31

      It is almost certain that your Linux distribution already contains PCMCIA support, unless it is a distribution intended for servers, so you shouldn't need to compile or install anything.

      To see if PCMCIA support is already on, try using PCMCIA commands like "cardctl info".  And check whether 'lsmod' shows any PCMCIA related modules.

      -- Dave