serial_cs shutdown lock-up (Linksys PCMLM56)

2004-12-08
2013-04-08
  • Grant Edwards

    Grant Edwards - 2004-12-08

    After upgrading from Mandrake 10.0 to 10.1, I know have a problem with PCMCIA: when I try to shutdown my system or when I unplug the card, I get a message "trying to free nonexistent resource <000002f8-000002ff>" and a hard lock-up.

    The port range in the above message is that which was allocated for the serial portion of the card.

    Upon insertion the card is detected, initialized, and operates fine (using serial_cs and pcnet_cs drivers).  The problem is that I can't unplug the card or shutdown the machine w/o locking it up. This card has worked fine for years and years under at least a dozen different Linux distros.

    Linksys PCMLM56 modem+Ethernet
    Dell Inspiron 5000
    Mandrake 10.1
    Kernel 2.6.8.1-12mdk
    pcmcia-cs 3.2.8-1mdk

    If I boot kernel 2.6.3-7mdk instead (still using the same version of pcmcia-cs), I still get the "tyring to free nonexistent resource" message when ejecting the card, but no lockup. However, the card won't work when it's re-inserted.

    How do I get this card to work again?

     
    • David Hinds

      David Hinds - 2004-12-15

      What about if you use "cardctl eject" before ejecting?

      You should really report 2.6 kernel PCMCIA problems here:

      http://lists.infradead.org/mailman/listinfo/linux-pcmcia

      -- Dave

       
      • Grant Edwards

        Grant Edwards - 2004-12-15

        Cardctl eject also causes a hard lockup. It's definitely a kernel/driver bug -- I didn't realize this wasn't project for the
        pcmcia *_cs drivers.

         
        • David Hinds

          David Hinds - 2004-12-20

          This is the appropriate place to report problems in *_cs drivers if you're using the ones included in the pcmcia-cs package.   But since I'm not the maintainer of the 2.6 kernel PCMCIA drivers, and am not that familiar with recent 2.6 kernel work, that mailing list is a better place to report problems with that code.

          - Dave

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks