APA 1480A and kernel 2.4.0 on a Latitude Cp80

2001-02-11
2001-02-16
  • Alfredo Ferrari

    Alfredo Ferrari - 2001-02-11

    I have plenty of problems in getting the pcmcia module working under a Dell Latitude Cp800 with
    Intel4451 controllers. The kernel built-in PCMCIA package does not work at all (kernel 2.4) hanging
    the machine whatever I do. I recompiled the kernel without the built-in pcmcia support, I built the
    pcmcia-cs-3.1.24 package configuring pnp as suggested by several threads about similar problems with Dell Latitude machines and eventually I was able to get my 3COM 3C575 cardbus ethernet adapter and my Psion modem work. Nice. Then I tried to get my APA1480A which works without a glitch on another Latitude under kernel 2.2.16/pcmcia 3.1.19 and the system bombs with a kernel panic whatever I do (I tried almost all possible combinations for the i82365 options).

    Unfortunately 2.2.16/3.1.19 does not work on this machine due to the new hardware (it kernel oops at boot time). I have the logs, the lspci log etc in case they can be helpful. The card had my standard SCSI devices (one HD, one CRW, one magneto optical drive) attached and powered when I booted. In the logs there are funny things like:
    Feb  9 22:26:38 pceet215 kernel: (scsi0) Wide Channel, SCSI ID=15, 0/255 SCBs

    while I know it should be SCSI ID=7 and Narrow Channel from the other machine

    I can see on the screen (but apparently not in the logs) a segmentation fault from the pcmcia script
    probably in cardmgr (difficult to say, the machine hangs just after).

    Any help is highly appreciated!

                Alfredo Ferrari

    +----------------------------------------------------------------------------+
    |  Alfredo Ferrari                ||  Tel.: +41.22.767.6119                  |
    |  CERN-SL                        ||  Fax.: +41.22.767.7555                  |
    |  1211 Geneva 23                 ||  e-mail: Alfredo.Ferrari@cern.ch        |
    |  Switzerland                    ||          Alfredo.Ferrari@mi.infn.it     |
    +----------------------------------------------------------------------------+

     
    • David Hinds

      David Hinds - 2001-02-12

      There is a new aic7xxx driver at

      http://people.freebsd.org/~gibbs/linux

      that is likely to fix the problem.  Apply the appropriate patch from this site to your kernel tree; you will also need to get the latest PCMCIA beta package from:

      ftp://projects.sourceforge.net/pub/pcmcia-cs/NEW

      -- Dave

       
      • Alfredo Ferrari

        Alfredo Ferrari - 2001-02-13

        Hi Dave

        thanks a lot for the suggestion. I have a couple of troubled days, but on thursday I'll try to follow your indications and I'll let you know if I succeed

                      Thanks a lot
                        Alfredo

         
    • Anonymous - 2001-02-16

      I faced the same problem trying to get an
      1480A to work with 2.4.2pre3 on a Inspiron 8000.

      Solution: pcmcia-cs (up to 3.1.25 from 6 Feb 2001)
      will hang the machine solid if not compiled with
      PnP resource checking (don't know why) as soon
      as cardmgr is started, even with nearly all
      ioports, irqs and iomem excluded.
      Will work fine when hacking the Makefile to
      include PnP.
      The APA180A only will work with the 6.1.x driver
      from Justin Gibbs, as this is the only one
      correctly recognizing the card with 2.4.x.

      Finally both my Xircom RBEM56G and the 1480A
      work flawlessly.

       

Log in to post a comment.