APA-1480B MEM region in use

2001-04-10
2001-04-10
  • Werner Heuser

    Werner Heuser - 2001-04-10

    Hi,

    using an Adaptec SlimSCSI 1480B I get these
    kernel messages, when inserting the card

    cs: cb_enable(bus 6)
      bridge io map 0 (flags 0x21): 0x800-0x8ff
      bridge mem map 0 (flags 0x1): 0x60020000-0x60030fff
    apa1480_attach(device 06:00.0)
    aic7xxx: PCI6:0:0 MEM region 0x60030000 in use. Cannot map device.
    ahc_pci:6:0:0: Host Adapter Bios disabled.  Using default SCSI device parameters
    scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.1.5
            <Adaptec 1480A Ultra SCSI adapter>
            aic7860: Single Channel A, SCSI Id=7, 3/255 SCBs

    According to the PCMCIA-HOWTO I tried to do some settings in
    /etc/pcmcia/config.opts (but I'm not sure I did it the right
    way, since my knowledge about kernel internals is not the best,
    I have some difficulties to understand this part of the HOWTO).

      +^Ho  The Adaptec APA-1480 CardBus card needs a large IO port window (256
         contiguous ports aligned on a 256-port boundary).  It may be
         necessary to expand the IO port regions in /etc/pcmcia/config.opts
         to guarantee that such a large window can be found.

    # System resources available for PCMCIA devices

    include port 0x100-0x4ff, port 0x800-0x8ff, port 0xc00-0xcff
    include memory 0xc0000-0xfffff
    include memory 0xa0000000-0xa0ffffff, memory 0x60000000-0x60ffffff

    # I tried this additionally for Adaptec SlimSCSI 1480B
    include memory 0x60030000-0xa0030000
    include memory 0x00000800-0x000008ff

    Additionally I read the recent bug reports, and followed the
    recommendation, to use the card only together with the cable.

    My kernel is 2.4.3 (PCMCIA disabled) PCMCIA-CS 3.1.25

    (BTW: with kernel 2.4.2 and PCMCIA-CS 3.1.24 I got a kernel panic
    with this card)

    Could you please explain the part of the HOWTO mentioned above
    in more detail? Or even better give a working example?

    Regards

    Werner

     
    • David Hinds

      David Hinds - 2001-04-10

      That section of the HOWTO does not refer to your problem, and I am not familiar with the error message you're getting.  I have not actually tried this card with a 2.4.3 (or even 2.4.2) kernel.

      -- Dave

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks