Toshiba 220CS + APA1480 + Ethernet

  • A. Spindler

    A. Spindler - 2002-01-07

    My setup:
    - Toshiba 220CS Laptop (P133, 48MB RAM)
    - Red Hat 7.2
    - PCMCIA Network Card Fiberline 10/100 Fast-Ethernet (16bit)
    - PCMCIA Adaptec SlimSCSI 1480A Adapter

    Problem: I cannot enable both PCMCIA cards. If I set the BIOS card-mode to "PICI Compatible" the network adapter works, but the
    SCSI adapter is not recognized. If I set the mode to "CardBus 16bit" (the only other setting) both adapters are recognized but the network adapter is dead. Swapping the sockets yields an equal results.

    The output of "cardctl status" is:
    Socket 0: 5V 16Bit, function 0 [read][wp[bat dead]
    Socket 1: 3.3V CardBus card, function 0 [ready]

    In this scenario, I plugged the network adapter into socket 0 and into socket 1 the 1480A. Obviously the state "[bat dead]"
    seems to denote a problem, but no documentation says how to interpret it. In /var/lib/pcmcia/stab for socket 0 "Anonymous Memory" is reported.

    I assumne memory cannot be assigned. I use the standard RH 7.2 settings of /etc/pcmcia/config.opts: 0xb0000000 to 0xffffffff plus some high-memory ranges. I set the range to 0x00000000-0xffffffff. I tried swapping the sockets. I booted with only the network card etc. Nothing did help.

    This situation prevents me for weeks from setting up my local network, so any help is greatly appreciated!!

    Regards from germany,
    A. Spindler

    • Javier Hernandez

      I do not know if it helps you but in my Toshiba Portege 3010CT I have config.opts files with some specific memory
      # System resources available for PCMCIA devices

      include port 0x100-0x4ff, port 0x800-0x8ff, port 0xc00-0xcff
      include memory 0xc0000-0xfffff
      include memory 0xa0000000-0xa0ffffff, memory 0x60000000-0x60ffffff

      If I do not use those lines my APA-1480 does not work
      properly in my system.

      Best regards,


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks