DWL-650 and D-Link AP 713P

Kar-Yeong
2001-08-22
2013-04-08
  • Kar-Yeong

    Kar-Yeong - 2001-08-22

    I have the DWL-650 card and the d-link 713P access point. I tried configuring the card on slackware with pcmcia package 2.2.27. Everything went fine but I seems to not able to connect to my access point (channel 6).. Anybody has the same setting that are willing to help?

    Thanks

     
    • Kar-Yeong

      Kar-Yeong - 2001-08-22

      I'm sorry, the pcmcia package is 3.1.27 instead.

       
    • Jean Tourrilhes

      Jean Tourrilhes - 2001-08-23

          1) Which driver are you using ?
          2) The Access Point has a bug, only the very latest orinoco_cs has the workaround.

          Jean

       
      • Kar-Yeong

        Kar-Yeong - 2001-08-24

        Thanks, I'll try the orinoco_cs, I think that's in the kernel, right?

         
    • Kar-Yeong

      Kar-Yeong - 2001-08-26

      got them to work, had to upgrade 713p firmware too

       
    • Anonymous - 2003-12-17

      I am a newbie just starting out so I have no idea at all on Linux.I just installed it on a laptop and have a wireless card DWL-650.I can not get it to work as far as I can see.I need help bad in order to get it to work I think.Can someone please help me out step by step to get this working?
      I have also tried the Linksys wpc11 card with same results.Yes I have either one that I can use to setup with.Please if you can help me,you can email me at n1rsp@qsl.net .I will thank you in advance.
      I am using a Gateway Solo 5300 laptop if that makes any difference.I loaded Redhat 9.0.

       
    • Ima Sudonim

      Ima Sudonim - 2003-12-17

      I am using a different router (netgear WGR614). I am also using yellowdog linux on a G3 powerbook (PPC), with a custom kernel 2.4.22.

      I can modprobe orinoco_cs

      But iwconfig eth2 still returns

      eth2 No such device

      /var/log/messages has
      modprobe: Can't locate module eth2

      /etc/sysconfig/networking/devices has
      ifcfg-eth2 defined and the information in it is right for my network

      cardctl ident returns:
      Socket 0:
      product info: "D-Link", "DWL-650 Wireless PC Card RevP", "ISL37101P", "A3"
      manfid: 0x000b, 0x7110
      function: 6 (network)

      So the pcmcia slot is working and the card is recognized.

      If I use the Network utililty that comes with YellowDog Linux PPC (a redhat version), then I can create a new adaptor (eth2). Hardware type: wireless.

      I have tried:
      Lucent Orinoco and Prism II-based pcmcia wireless,
      AT&T/Lucent WaveLAN/DEC RoamAbout PCMCIA wireless,
      D-Link DE-650/Linsys Ethernet Card (NS8390) PCMCIA
      I save the configuration.

      I restart the network and pcmcia services
      /etc/rc.d/init.d/network restart
      /etc/rc.d/init.d/pcmcia restart

      Yet the new card is NOT there (where is this eth2 device stuff stored anyway?)

      If I run the Network tool again the adapter eth2 is GONE.

      The wired eth0 and airport card (eth1) are there and work fine. 8-)

      The wireless source in my kernel says is it 0.13d, BTW. I am using kernel 2.4.22-stable

      Thanks!

       
    • John Richard Moser

      there's another revision of the card you probably have.  It uses the adm8211 chipset, not orinoco; and revision 20 doesn't yet work under the adm8211 chipset.  There's experimental code at:

      http://aluminum.sourmilk.net/adm8211/

      I have one of these cards if the pcmcia-cs project would like me to ship it to them; but I need it back in one piece when you've got a working driver ;)  It's useless to me up to then.  I need one for 2.6 :)

       
      • John Richard Moser

        Rather, should say, I could *try* to ship it; but I don't know how and have no money so I'd have to get some off my dad :)

         
    • David Petruncola

      I'm running this driver without problem, on my admtek based DWL650.
      Just be sure to pick a version that is compatible with the kernel you run.

      Dave

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks