Linksys WPC11v4 not detected - cardctl ident

  • Jasper

    Jasper - 2004-12-20

    I'm trying to get this card to work. At the moment I'm stuck at identifying the card, cardctl ident shows 'no product info available'. I'm using kernel 2.6.9 and know for a fact that cardctl works with an old Knoppix cd based on a 2.4.x kernel. PCMCIA card services startup without error, and the cards' powerled is on.

    Some specs & output:

    Dell Inspiron 9100

    Kernel 2.6.9, PCMCIA, HOTPLUG and CARDBUS compiled in (also tried modules).

    Card services version (gentoo):
    *  sys-apps/pcmcia-cs
          Latest version installed: 3.2.5-r1

    Startup info:
    * Starting pcmcia...
    cardmgr[10122]: watching 1 socket                                         [ ok ]

    The card shows up in lspci output:
    0000:03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8180L 802.11b MAC (rev 20)
            Subsystem: Linksys: Unknown device 0019
            Flags: medium devsel, IRQ 19
            I/O ports at 4000 [disabled]
            Memory at 40800000 (32-bit, non-prefetchable) [disabled] [size=512]
            Capabilities: [50] Power Management version 2

    # cardctl status
    Socket 0:
      3.3V CardBus card
      function 0: [ready]

    # cardctl info

    # cardctl ident
    Socket 0:
      no product info available

    yenta output:
    Yenta: CardBus bridge found at 0000:02:01.0 [1028:0159]
    Yenta: ISA IRQ mask 0x0cf8, PCI irq 19
    Socket status: 30000020
    cs: IO port probe 0x0c00-0x0cff: clean.
    cs: IO port probe 0x0800-0x08ff: clean.
    cs: IO port probe 0x0100-0x04ff: excluding 0x4d0-0x4d7
    cs: IO port probe 0x0a00-0x0aff: clean.

    Any help would be greatly appreciated !

    • David Hinds

      David Hinds - 2004-12-20

      The "no product info available" message is not an error.  It's just a fact that your card doesn't provide this information; this is not unusual for CardBus cards.

      The card does show up in 'lspci' which is all that's needed for it to be identified.  Perhaps the hotplug subsystem didn't know what to do because there was no appropriate driver available?  You could check your system log to be certain.

      -- Dave

      • Jasper

        Jasper - 2004-12-20

        David, thanks for your swift reply.

        I solved the problem just now. I thought that the problem was in the pcmcia layer as the ident failed but it obviously was not. I installed ndiswrapper in combination with the Realtek 8180 driver. It's working just fine now :)

    • Jboegen

      Jboegen - 2005-10-06

      I guess I can get the driver at and look for 8180; but which driver do I use, the one for Win XP ?


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks