#238 to high depends on configure and compilation

closed
nobody
None
5
2012-08-10
2012-07-24
No

i compile and package venenux release of pcmanfm with valac 0.12 and glib 2.24, but configure said must be valac 0.13 as minimun and glib 2.26 (wich depends on gobject-2.0 2.26 +)

i revised before compiled, code and in libfm theres no lines for gobject instrocpection,an valac its only used for stupid thing, so i suggest for LIGHT DEKSTOP (that its only usefully in older machines thaaattt dont have too high software installled) reduce and modified code..

i think developer use windoze like distributions that install too high software for "light" dekstop.. and the autotools generate unused depdns (obviously produced by valac release instaled)

so before send this report i test enough the binaries and works as well, and problems i found are not related to valac or gobject (that its not used for any runtime operation of course hum)

as i said:

there's no fun in a light desktop (software) if required a high dektops (hardware)...

Discussion

  • Lonely Stranger

    Lonely Stranger - 2012-07-25
    • labels: 805537 -->
     
  • Lonely Stranger

    Lonely Stranger - 2012-07-25

    Thank you very much for the testing. You're talking not about old hardware but about old software instead. If newer software doesn't work on old hardware then it should be fixed but you're pointing at old enough software. And it's not next generation (thinking of introspection mentioned by you, which is gtk-3.0 feature) of the library but the same just old. And you know, another version of glib can give weirdness even if it could compile without warnings (which, BTW, can be checked if configured with --enable-debug and looked for any warnings - it shouldn't give any except some from vala).

     
  • PICCORO Lenz McKAY

    Try to explain my point, and of many people in latin american and other minor country (like african people or taiwan) because otherwise there is no sense to use lightweight software :

    If my system requires very high dependences, these obviously by law (in a great majority of cases) will require more hardware! Understand at last?

    as i said: there's no fun in a light desktop (software) if required a high dektops (hardware)...

    however, I discovered many segfaults if not compiling against glib 2.26 as a minimum, and 0.13 vala as minimun, and i cannot instance more than one filemanager threath in this cases..

    over leading the development, I doubt that in the future and interested in using pcmanfm as "light version" and may not be compiled on old desks, as these are what are on old machines ..

    my desire for a recent pcmanfm is because the tree side panel, and desktop management are essential, I have been waiting in hopes a recent version with support for tree and links on the desktop .. but I'll end up using razorqt that compiles with older software (already installed on older machines)

    I hope common sense empire and take into us, account users who do not use windo .. because it seems that this its just like Microsoft, more and more requirements ..

     
  • Lonely Stranger

    Lonely Stranger - 2012-07-25

    I'm sorry but I cannot see the point in not using just a bit less expired version of glib. You mean if you install a bit more recent version of library it will take another dependencies which are resource expensive for your hardware? I'm not talking about high version (i.e. gtk-3.0) but about the same gtk-2.0 but a bit updated. Or is it too hard to update glib in your configuration?

     
  • PICCORO Lenz McKAY

    u cant understand? men! i updated from 2.16 to 2.22, and again to 2.24 and again now to 2.26 the glib???????? !!!!

    i cant standt in upgrades always! i just only want to compile a pcmanfm.. theres no sence in constants upgrades (like mocosoft)

    "a bit updated" like winbuntu ? always updates and updates?

    a pemtium3 with 128 ram runs lxde and pcmanfm perfectly but in 2 years not with gtk+ 2.22 and glib 2.26 runs "a bit" slower" men understant that!

     
  • Lonely Stranger

    Lonely Stranger - 2012-07-25

    Ah, I see. OK, we'll check what we can do to let it work well with older glib too. Thank you.

     
  • PICCORO Lenz McKAY

    i glad to see u pay attentio to this, thanks for that.. my hope and the hope of many are on us..

     
  • Lonely Stranger

    Lonely Stranger - 2012-08-08

    I've tested version 1.0.1-beta with gtk+ 2.20 and glib 2.24. It should be configured with --disable-actions though to disable vala-related things and it works fine then. That version is in the branch and will be in master branch after 1.0 is released. If you're desperate to test then you can get libfm with:

    git clone git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/libfm
    cd libfm
    git checkout 1.0.1-beta

    pcmanfm you can get with:

    git clone git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm
    cd pcmanfm
    git checkout 1.0.1-beta-fixes

    Use instructions on the wiki how to compile it from the Git code.

     
  • PICCORO Lenz McKAY

    now cloning and testing, if work i mantaint a clone in github.. for testing purposes and packagin..

     
  • PICCORO Lenz McKAY

    errr sorry but:
    fatal: unable to connect to pcmanfm.git.sourceforge.net:
    pcmanfm.git.sourceforge.net[0: 216.34.181.91]: errno=Conexi?n rehusada
    umm tell me something please..

     
  • Lonely Stranger

    Lonely Stranger - 2012-08-08

    I don't see any problems with git://pcmanfm.git.sourceforge.net right now. Try it again, please, it might be some temporary error.

     
  • Lonely Stranger

    Lonely Stranger - 2012-08-09

    I'm sorry but don't get those sources yet, I've broken them it seems - libfm-demo does work fine (even on my test system with GLib 2.22 and Gtk 2.18) but pcmanfm doesn't. I'll tell you when I fix it. Thank you.

     
  • Lonely Stranger

    Lonely Stranger - 2012-08-09

    I think I've fixed it and it works well on my virtual box with old GLib/GTK. So if you want to test it then you're the most welcomed. It's really 1.0.1beta (and has all bugs marked for 1.0.1 fixed in it, yes) but it's labeled 1.0rc1, just ignore that. Report any problems you find, please. Thank you.

     
  • PICCORO Lenz McKAY

    in previously pcmanfm this king of broke on pcman appears, since 0.9.9 .. the git error its cos i'm in a intranet, so now i get test compile at cybercafe and go to work.. i'll notice u any trace i found.. with gdb

     
  • PICCORO Lenz McKAY

    WOOORRRRKKKKK

    BBUUAAAHHH A'M so happpyynneeesssssss shif snif

    a long long ago from 0.9.7 to 1.0.1 its the best! !!!!!

    some minor mistakes, preferences dont show, i'm debugging for that but i dont care of jajajaja, i send u some info later in few days.. close that!

     
  • PICCORO Lenz McKAY

    grr file updates reflect dont work.. so i dont know if closed.. i'm revise and compiling with valac 0.14

     
  • Lonely Stranger

    Lonely Stranger - 2012-08-10

    Thank you very much for diagnostics. I'll find why preferences dialog doesn't work.
    And about valac - using valac require glib 2.26 at least so don't try.
    And what you mean by "file updates reflect"?

     
  • Lonely Stranger

    Lonely Stranger - 2012-08-10

    Preferences dialog is now fixed in the branch. Thank you.

     
  • PICCORO Lenz McKAY

    ok now showit but i note that after 0.9.7, file monitoring now relies in libfm and not in fam/gamin, so in pcmanfm 0.9.7 when i delete, rename or move files, the windows refresh and updates instantaneus, but now since 0.9.8 and + this dont work,

    i use/test that with gtk+ 2.18/2.20 and glib2 2.22/2.24/ and now with gligb2 2.26,

    But now in this new version is worse, because the automatic update file operations (update/delete a file in a directory, then this "item" (file) must disaper from the view of that directory) are not reflected, and apart from , now pcmafn file manager crash, the crash are more frecuently when pcmanfm manage the desktop or move icons.

    should i debug and paste ooutput for that? this problem are since 0.9.8 and libfm 0.1.14 , of course try to use lower versions of gtk+ and glib due there's no sense in newer libraryes, due this newers software requires more machine, and if a user have more mchine/hardware install a desktop more greater..

    i like very much the lxde and related projects due runs in my olders K6-III and PIII machines, and mani users from latin america uses now lxde even gnomepuach...

     
  • PICCORO Lenz McKAY

    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks