SourceForge has been redesigned. Learn more.
Close

#893 Thumbnails not refreshing on filesystem changes

1.2
pending
libfm (305)
5
2015-05-19
2014-07-25
AntumDeluge
No

If I have PCManFM open & I create a new image file in the working directory using an external app a new file appears with a generic icon. But I have to manually refresh to get the thumbnail to show. I'm not 100% sure whether this is an issue with PCManFM or my system.

System Info:
FreeBSD 10.0 amd64
UFS / UFS2 Filesystem
lxde (lxde-meta) 1.0_7
PCManFM 1.2.1 (built from FreeBSD Ports collection)

There is a comment in the lxde package for FreeBSD: '"meta-port" of the LXDE desktop slimmed down for FreeBSD releases'. Not sure if this has any affect on PCManFM

Discussion

  • Lonely Stranger

    Lonely Stranger - 2014-08-23

    Unfortunately I cannot reproduce your issue with LibFM 1.2.1. Are you sure your LibFM is the latest version? I can remember similar issues in pre-1.2.1 versions. Thank you very much.

     
  • Lonely Stranger

    Lonely Stranger - 2014-08-23
    • labels: thumnail, filesystem, preview, zfs --> libfm
    • status: open --> pending
    • assigned_to: Lonely Stranger
     
  • AntumDeluge

    AntumDeluge - 2014-08-25

    Installed libfm version is 1.2.1.

     
  • Lonely Stranger

    Lonely Stranger - 2014-10-01

    Since I cannot reproduce that behavior on Linux I'm afraid it's some kqueue problem which prevents GLib from notifying applications about file updates. :(

     
  • Lonely Stranger

    Lonely Stranger - 2014-10-13

    This also may be due to some strange updates sequence from GLib on FreeBSD. Updates handling was a bit changed lately in libfm GIT. Test it, please, when you can, it might fix your issue. Thank you.

     
  • AntumDeluge

    AntumDeluge - 2014-10-13

    I still have the same behavior: PCManFM 1.2.2 & libfm 1.2.2.1.

     
  • Lonely Stranger

    Lonely Stranger - 2015-05-19

    Well, I meant exactly: "lately", i.e. in 1.2.3. I really hope it is fixed now, as some similar issues were noticed still in 1.2.2.1, and fixed in 1.2.3. Try it, please. Thank you.

     

Anonymous
Anonymous

Cancel  Add attachments