#723 Crash on various actions on desktop icons

1.2
closed-invalid
libfm (303)
7
2013-05-07
2013-05-04
Journeyman
No

I am experiencing this after it disappeared in Lubuntu 12.10 from Lubuntu 12.04.
I've upgraded to lubuntu 13.04 and it appeared again.

In order to reproduce this error:
1) Kill pcmanfm from console
2) Start "pcmanfm --desktop-pref" and TICK "show menu provided by window managers when desktop is clicked"
3) Start "pcmanfm --desktop" (either with or without a "--profile" parameter)
4) Right click on an icon on the desktop
4.1) Double click on an icon on the desktop
4.2) Select an icon and press RETURN
5) Crash

Alternate:
4b) Right click on the desktop (anywhere but an icon)
5b) Does not crash

Alternate:
2c) Start "pcmanfm --desktop-pref" and UNTICK "show menu provided by window managers when desktop is clicked"
3c) Start "pcmanfm --desktop" (either with or without a "--profile" parameter)
4c) Right click on an icon on the desktop OR anywhere on the desktop
5c) Crash

Basically it looks that the menu provided by lxde makes pcmanfm crash.

NOTES:
1) as suggested I tried to install libfm-dbg (success) but I could not install pcmanfm-dbg beacuse of the Ubuntu dependency hell. I cannot remove pcmanfm because it would tear apart my distribution nor I am allowed to install pcman-dbg because I have pcmanfm package in place.
So I'm afraid that at this time I cannot provide a useful stacktrace other than the attached one.
2) Tried running a fresh install of Lubuntu 13.04 on a virtual machine and the error never show up: I must assume that the culprit is some old GTK (?) lib from Lubuntu 12.04 or 12.10.
3) Tried cloning the current git repo and compile. That specific issue does not show up.

If there's anything more I can provide, please let me know. As a last resort I will wipe out the distro and reinstall 13.04 (I love this file manager, don't want to switch to anything else at this time).

Regards,

Discussion

  • Journeyman

    Journeyman - 2013-05-04

    pcmanfm stacktrace

     
  • Lonely Stranger

    Lonely Stranger - 2013-05-07

    Thank you very much for your bugreport. It is very strange that libfm-dbg showed you success but still not appeared in listing (dpkg -l). If it was there then your backtrace could provide a bit more useful information. It probably should be libfm4-dbg instead. To be honest, line
    0x00007ffff786941d in fm_folder_view_item_clicked () from /usr/lib/x86_64-linux-gnu/libfm-gtk.so.4
    is not much useful and may give only some estimation what really happened. But since you provided detailed recipe to reproduce it, I'll try to find out what happened.
    As much as I can see you're using packages from lubuntu-daily repository so you gave me very early bug feedback (since that repository presents you experimental version of libfm - development of next release 1.2) and that's pretty much appreciated. The 1.2 version already got a lot of new features, BTW, see http://pcmanfm.git.sourceforge.net/git/gitweb.cgi?p=pcmanfm/libfm;a=blob;f=NEWS and feel free to report any bugs in them if you happen to find any. Thanks.

     
  • Lonely Stranger

    Lonely Stranger - 2013-05-07
    • assigned_to: nobody --> lstranger
    • priority: 5 --> 7
    • milestone: --> 1.2
    • labels: --> libfm
     
  • Lonely Stranger

    Lonely Stranger - 2013-05-07

    I think I know what was the problem. Your pcmanfm was made 19.04.2013 but libfm is from 22.04.2013 and there was a commit 206ae070b2f49cba0ed3533d8a130c2c611d8912 in between which has made those versions incompatible therefore you desktop clicking should've certainly cease to work. That is the price of using experimental version of software which is still in development. There will be no such situations anymore when version 1.2 come into beta state.
    I believe if you just do 'apt-get update && apt-get upgrade' then both libfm and pcmanfm will be updated and your problem disappear. Check it please and feel free to reopen the report if problem is still there.

     
  • Lonely Stranger

    Lonely Stranger - 2013-05-07
    • status: open --> closed-invalid
     
  • Journeyman

    Journeyman - 2013-05-07

    Hello,

    you are right, weeks ago I've added lubuntu-daily to my sources.list (I think it was trying to eliminate a tedious bug in lxession), so I've polluted my system with unstable packages.
    I've tested your suggestion too: re-adding the lubuntu-daily to my sources and download the very latest libfm packages (201305061705 build) to no avail.

    However I fixed my problem using synaptic and reverting the libfm-* and pcmanfm packages to the standard raring version.
    From now on I will stay away from lubuntu-daily, lesson learned :^)

    Anyway, thank you so much for your prompt and useful help, that was much appreciated.

     
  • Journeyman

    Journeyman - 2013-05-07
    • status: closed-invalid --> open-invalid
     
  • Lonely Stranger

    Lonely Stranger - 2013-05-07
    • status: open-invalid --> closed-invalid
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks