#705 Pasting doesn't work with CTRL + V

1.2
closed-fixed
libfm (303)
5
2014-03-28
2013-01-25
Sworddragon
No

I have already posted this bug some time ago but I have found an explanation for this (focus on the address bar). But the bug is still appearing on PCManFM 1.1.0 and in my OpenBox configuration is no action defined for C-V. To be more precise:

If I'm copying a file or directory with CTRL + C and pasting it to another directory with CTRL + V sometimes nothing happens. But using the context menu for pasting is working fine in this case. The last time you have said the context menu and pasting with CTRL + V are using the same code but there is definitely something wrong.

Discussion

  • Lonely Stranger

    Lonely Stranger - 2013-02-12
    • milestone: --> 3172103
    • labels: --> libfm
     
  • Lonely Stranger

    Lonely Stranger - 2013-04-19

    Yes, context menu and Ctrl+V use the same code. But you know, when you open context menu then folder view is definitely focused at that moment. When you press Ctrl+V it may be not the case. It would be nice if you could explore the issue further and tell us where is the focus at the moment. Thank you very much.

     
  • Sworddragon

    Sworddragon - 2013-04-19

    Normally I'm selecting a file, pressing CTRL + C to copy it, browing into the destination folder with many double clicks and pressing then CTRL + V. Most times this is working but sometimes not. If it is not working further presses of CTRL + V doesn't help. Even clicking with the mouse into an empry place of the folder and pressing CTRL + V again doesn't help. PCManFM has definitely in all this cases the focus to its main window.

     
  • Lonely Stranger

    Lonely Stranger - 2013-04-19

    That is very much odd. I could think it's related to another bug (https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/1071231) which is currently fixed in GIT but that bug probably shouldn't happen after clicking on the folder itself. It would be good if you could test it with libfm branch '1.1' (which is a branch of future bugfix version 1.1.1) where mentioned fix is applied, that might fix this issue despite of I think of it.

     
  • Lonely Stranger

    Lonely Stranger - 2013-07-22
    • milestone: 3172103 --> 1.2
     
  • Lonely Stranger

    Lonely Stranger - 2013-08-15
    • assigned_to: nobody --> lstranger
     
  • Lonely Stranger

    Lonely Stranger - 2013-08-15

    I would like to know if this issue is fixed for you in version 1.1.2. Thank you.

     
  • Sworddragon

    Sworddragon - 2013-08-15

    I'm already looking for this bug but it is not easy to tell if it is really fixed because the bug has a random reproducibility rate:

    1. If it is not fixed it can need many days until it appears again.
    2. If it is fixed I will need some weeks to verify it.

    If all is workng fine I will close this ticket in 1 month.

     
  • Sworddragon

    Sworddragon - 2013-08-19

    The bug still appears on PCManFM 1.1.2. But I have figured out something new: After PCManFM had the focus (I have clicked several times on an empty place of the directory) and pressing CTRL + V still failed I have left-clicked any file and then left-clicked an empty place in the directory again. After this pressing CTRL + V worked. My theory: Something prevents PCManFM to get the focus internally in some cases if I'm clicking on an empty place. The left-click on the file has outbreaked this and given finally the focus to PCManFM).

     
  • Lonely Stranger

    Lonely Stranger - 2013-09-01

    Thank you very much for your research. I got the idea how that might happen and I hope this issue is completely fixed in the Git repository now.
    Test it when it's possible for you and if the bug still exists then reopen the report, please.

     
  • Lonely Stranger

    Lonely Stranger - 2013-09-01
    • status: open --> closed-fixed
     
  • Cristiano Nunes

    Cristiano Nunes - 2013-10-14

    Hello, I'm using PCManFM and libfm from GIT 2013/10/10 and the bug still appears.

     
  • Lonely Stranger

    Lonely Stranger - 2013-10-20

    I pretty much hope the bug is finally fixed by the latest commit into GIT. Test it, please, when you can.
    Thank you very much.

     
  • Lonely Stranger

    Lonely Stranger - 2013-10-20
    • status: closed-fixed --> pending-fixed
     
  • Lonely Stranger

    Lonely Stranger - 2014-03-28

    Since no negative answer was given I suppose it is really fixed so I close this report. Thanks.

     
  • Lonely Stranger

    Lonely Stranger - 2014-03-28
    • status: pending-fixed --> closed-fixed
     
  • Sworddragon

    Sworddragon - 2014-03-28

    I'm currently ~1 month on PCManFM 1.2.0 with LibFM 1.2.0 and the bug hasn't appeared anymore in this time so it seems it is really fixed.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks