#677 Copy & paste doesn't work correctly

1.1
closed-invalid
libfm (303)
5
2012-11-23
2012-11-23
Sworddragon
No

I'm using PCManFM 1.1.0 and sometimes copying a file from the root instance of PCManFM to my user instance of PCManFM doesn't work. But only pasting with Ctrl + v is broken and a workaround is to use the contect menu in this case. Curiously I can't reproduce the bug in every case. The most times it is working fine.

Discussion

  • Sworddragon

    Sworddragon - 2012-11-23

    Oh, I have posted this in the wrong tracker. This report should be moved to the Bugs tracker.

     
  • Lonely Stranger

    Lonely Stranger - 2012-11-23

    Both the Ctrl+V and the context menu run exactly the same code - the Ctrl+V is a hotkey to the 'Paste' context menu item. So I believe your problem lies somewhere else.
    Thank you.

     
  • Lonely Stranger

    Lonely Stranger - 2012-11-23
    • labels: --> libfm
    • milestone: --> 1.1
     
  • Sworddragon

    Sworddragon - 2012-11-23

    My window manager is Openbox but in /home/sworddragon/.config/openbox/lxde-rc.xml and /etc/xdg/openbox/rc.xml isn't any action for Ctrl+V defined. Maybe I will figure out the next time the bug appears a way to reproduce it. Or maybe it will magically fixed in the future.

     
  • Sworddragon

    Sworddragon - 2012-11-23

    I have made some more tests and found a potential way for this problem. If a file was copied and the address bar gains the focus a paste to the directory will not work. I think this happens because PCManFM tries to paste the content as a string to the address bar (but this fails because the source is an object in the file system).

    But if PCManFM loses the focus (for example by surfing in the internet with Firefox) and regains the focus the address bar has still the focus. Maybe this was the problem which confused me (or there is still another thing which triggers this problem).

    In my opinion there are 3 ways to solve the above problem:
    1. If the address bar has the focus and a paste is done PCManFM chekcs if the source is an object in the system and if this is true it pastes it to the destination.
    or
    2. If the address bar is focused and PCManFM loses the focus the address bar should be internally unfocused too.
    or
    3. All stays as it is.

     
  • Lonely Stranger

    Lonely Stranger - 2012-11-23
    • assigned_to: nobody --> lstranger
    • status: open --> closed-invalid
     
  • Lonely Stranger

    Lonely Stranger - 2012-11-23

    That hotkey isn't global action but per-window one instead so it is defined by application itself (i.e. pcmanfm) and I've described how it is programmed in pcmanfm - it's bound to context menu 'Paste'. Therefore it's impossible to have different behavior for Ctrl+V and 'Paste' in context menu.
    There is an only possible case - it is if your keyboard focus isn't on Folder, in that case your keyboard action will try to paste it into something else and fails, of course, since pcmanfm main window accepts Paste only in Folder or in Path Entry but nowhere else.
    Thank you very much.

     
  • Lonely Stranger

    Lonely Stranger - 2012-11-23

    Oh, you've found the problem yourself while I wrote answer. :)
    The keyboard focus doesn't roam over window and stays always where it was before you've switched between windows, that is one of common main principles which each window manager follows strictly.
    To solve your problem just don't forget to press 'Enter' when you changed a path in a Path Entry - when path selection is finished, pcmanfm will shift keyboard focus automatically to Folder.
    Thank you very much.

     
  • Sworddragon

    Sworddragon - 2012-11-23

    > To solve your problem just don't forget to press 'Enter' when you changed a
    > path in a Path Entry - when path selection is finished, pcmanfm will shift
    > keyboard focus automatically to Folder.

    There is one exception: If the path doesn't change but enter is pressed the focus will get behind the last character in the address bar instead to the folder.

     
  • Sworddragon

    Sworddragon - 2012-11-23
    • status: closed-invalid --> open-invalid
     
  • Lonely Stranger

    Lonely Stranger - 2012-11-23

    This last is definitely a bug but subject of this report states another one. So either change the subject or open another report.
    I'll explore the described behavior in any case.
    Thank you very much.

     
  • Sworddragon

    Sworddragon - 2012-11-23

    I have opened a new ticket and will close this one.

     
  • Sworddragon

    Sworddragon - 2012-11-23
    • status: open-invalid --> closed-invalid
     


Anonymous

Cancel  Add attachments