#659 'pcmanfm --desktop' fails/crashes under this circumstance...

1.1
closed-fixed
pcmanfm (122)
7
2012-11-20
2012-11-09
No

If 'pcmanfm --desktop' is opened in a run dialogue or autostarted for the session, pressing, say, 'down arrow' to activate first desktop item fails.
In Icewm pcmanfm desktop crashes and in Xfce it just fails to grab the focus.

If after starting the session or starting pcmanfm desktop we activate the window manager with some keyboard or mouse action (like changing workspaces etc.) then using the arrow keys work properly to select desktop item.

In IceWM I think I got a BT by running gdb in another VT so I could reproduce the bug (if I had run gdb in the same display then WM would be activated and desktop selection would work):

http://pastebin.com/jm7aGZxN

As a comparison, xfdesktop works properly both in Icewm and Xfce.

Discussion

  • Lonely Stranger

    Lonely Stranger - 2012-11-10
    • milestone: --> 2334032
    • priority: 5 --> 7
     
  • Lonely Stranger

    Lonely Stranger - 2012-11-20
    • assigned_to: nobody --> lstranger
    • milestone: 2334032 --> 1.1
    • status: open --> closed-fixed
     
  • Lonely Stranger

    Lonely Stranger - 2012-11-20

    I hope I've fixed the issue. Let me know if it is fixed for you with latest pcmanfm GIT changes, please.
    Thank you very much.

     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-11-20

    Seems to be working just fine. Thank you very much.

     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-11-20
    • status: closed-fixed --> open-fixed
     
  • Lonely Stranger

    Lonely Stranger - 2012-11-20

    Don't reopen bug if fixed, keep it closed, please, Thank you. :)

     
  • Lonely Stranger

    Lonely Stranger - 2012-11-20
    • status: open-fixed --> closed-fixed
     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-11-20

    Hm, there must be a bug in sourceforge because I didn't touch the bug status.
    Now after this comment if it opens again, don't worry, I come back and close it ;-)

     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-11-20
    • status: closed-fixed --> open-fixed
     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-11-20

    Yep, that's what happens. When refreshing the page the comment is open.
    So, closing.

     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-11-20
    • status: open-fixed --> closed-fixed
     
  • Lonely Stranger

    Lonely Stranger - 2012-11-20

    It's not bug but rather feature - if requestor comments own ticket then the default status is set to 'Open'. You should choose 'Closed' manually if you want not to reopen it. :)

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks